summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-08 00:22:05 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-08 01:45:19 +0100
commit3c8008f859c3fe5bd39bb5fe13c38e07dd67004b (patch)
tree0615741a5cd1ee031b4d68289934027bd84f4c3e /dev-python/dnspython
parentdev-python/boto3: Bump to 1.16.51 (diff)
downloadgentoo-3c8008f859c3fe5bd39bb5fe13c38e07dd67004b.tar.gz
gentoo-3c8008f859c3fe5bd39bb5fe13c38e07dd67004b.tar.bz2
gentoo-3c8008f859c3fe5bd39bb5fe13c38e07dd67004b.zip
dev-python/dnspython: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-2.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index 30c14b535b94..1018bfd4179d 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,2 +1,3 @@
DIST dnspython-1.16.0.tar.gz 167172 BLAKE2B a246684aae8651d94b4312a4b4cce2236a0c4f2289a8fe8a2bb8e81c6beddf6e81a7d54928bc50f950fde862b27e589e83fa9f7aaff7d263a6442f47fe9bb3bb SHA512 825a1815855e036ea1dfece6ec0d42242f83163960439ecba3da58d9adb85b65dda7e628cf38c386807a6c0c36aa026d5e95f7a1bdc2927aa2f6f042f873c14c
DIST dnspython-2.0.0.tar.gz 221903 BLAKE2B 540fb5fb12791dad6bae4007a77201092c8d5e64b7d82b23d5e3d16f48b49f73c90b85a6c8a83fa056a35cf7975ea2ad4a030f2b1fb1b87948bf1703adabb9d6 SHA512 3b38850fcacb0dd25ac0345201474f297c402617e8d706f3061c42172d697103075098e62ca0ac4e0e29967e00407f32f41789ac7bf070fba5aec0af9882e0fb
+DIST dnspython-2.1.0.tar.gz 279625 BLAKE2B ac90f1c9b50a00924326437e08513df04f3cf6dddee8b5ce58e628beab625d00c2dcdcc89e4b4da2c0366e650a5d8e87eb010942303215d3095e35f2010d4928 SHA512 eb3ab812eb8769b4780055b801e4f89beb1cb3d3e5a4855e583dca83b794eb7fca8fc3ef401eea7c16c34452e801dec5a2c59304f4041a68c7214dea6076435a
diff --git a/dev-python/dnspython/dnspython-2.1.0.ebuild b/dev-python/dnspython/dnspython-2.1.0.ebuild
new file mode 100644
index 000000000000..cc5faeca7385
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="https://www.dnspython.org/
+ https://pypi.org/project/dnspython/"
+SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -i -e '/network_avail/s:True:False:' \
+ tests/*.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}