summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-30 11:05:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-30 13:03:49 +0100
commit455634fa7080a3aa5437871558552d722efbfe70 (patch)
treedc1c0108eb80329c3566acb699839af5c1081ad0 /dev-python/dnspython
parentsci-biology/rebase: Version Bump (diff)
downloadgentoo-455634fa7080a3aa5437871558552d722efbfe70.tar.gz
gentoo-455634fa7080a3aa5437871558552d722efbfe70.tar.bz2
gentoo-455634fa7080a3aa5437871558552d722efbfe70.zip
dev-python/dnspython: Conver to py ABI slotted ebuilds
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=484954 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/dnspython-1.11.1.ebuild5
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r1.ebuild73
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r200.ebuild (renamed from dev-python/dnspython/dnspython-1.12.0.ebuild)17
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r300.ebuild43
4 files changed, 57 insertions, 81 deletions
diff --git a/dev-python/dnspython/dnspython-1.11.1.ebuild b/dev-python/dnspython/dnspython-1.11.1.ebuild
index ea07615a4886..3969929b281c 100644
--- a/dev-python/dnspython/dnspython-1.11.1.ebuild
+++ b/dev-python/dnspython/dnspython-1.11.1.ebuild
@@ -17,7 +17,10 @@ KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd
IUSE="examples test"
DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !dev-python/dnspython:py2
+ !dev-python/dnspython:py3
+"
DOCS=( ChangeLog README )
diff --git a/dev-python/dnspython/dnspython-1.12.0-r1.ebuild b/dev-python/dnspython/dnspython-1.12.0-r1.ebuild
deleted file mode 100644
index 450cb0340943..000000000000
--- a/dev-python/dnspython/dnspython-1.12.0-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1 multilib
-
-PN3="${PN}3"
-P3="${PN3}-${PV}"
-
-DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
-SRC_URI="
- http://www.dnspython.org/kits/${PV}/${P}.tar.gz
- http://www.dnspython.org/kits3/${PV}/${P3}.zip"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="examples test"
-
-DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
- app-arch/unzip"
-RDEPEND="${DEPEND}"
-
-S2="${S}"
-S3="${WORKDIR}/${P3}"
-
-# For testsuite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-s_locator() {
- if python_is_python3; then
- einfo "Setting \${S} to ${S3}"
- S="${S3}" $@
- else
- einfo "Setting \${S} to ${S2}"
- S="${S2}" $@
- fi
-}
-
-python_prepare() {
- s_locator distutils-r1_python_prepare
-}
-
-python_compile() {
- s_locator distutils-r1_python_compile
-}
-
-python_install(){
- s_locator distutils-r1_python_install
-}
-
-my_test() {
- pushd tests &> /dev/null
- "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
- einfo "Testsuite passed under ${EPYTHON}"
-}
-
-python_test() {
- s_locator my_test
-}
-
-python_install() {
- s_locator distutils-r1_python_install
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/dnspython/dnspython-1.12.0.ebuild b/dev-python/dnspython/dnspython-1.12.0-r200.ebuild
index 9edf38a91b37..6bb0c4b92558 100644
--- a/dev-python/dnspython/dnspython-1.12.0.ebuild
+++ b/dev-python/dnspython/dnspython-1.12.0-r200.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
@@ -12,21 +13,23 @@ HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
LICENSE="ISC"
-SLOT="0"
+SLOT="py2"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="examples test"
-DEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ !dev-python/dnspython:0"
+DEPEND="${RDEPEND}
+ !dev-python/dnspython:0
+ app-arch/unzip"
-# For tests
+# For testsuite
DISTUTILS_IN_SOURCE_BUILD=1
python_test() {
- pushd "${BUILD_DIR}"/../tests &> /dev/null
+ cd tests || die
"${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
einfo "Testsuite passed under ${EPYTHON}"
- popd &> /dev/null
}
python_install_all() {
diff --git a/dev-python/dnspython/dnspython-1.12.0-r300.ebuild b/dev-python/dnspython/dnspython-1.12.0-r300.ebuild
new file mode 100644
index 000000000000..a32c94ace073
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.12.0-r300.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4} )
+
+inherit distutils-r1
+
+MY_PN="${PN}3"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits3/${PV}/${MY_P}.zip"
+
+LICENSE="ISC"
+SLOT="py3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ !dev-python/dnspython:0"
+DEPEND="${RDEPEND}
+ !dev-python/dnspython:0
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}