summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-05 12:16:45 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-05 12:16:45 +0200
commit6522e7d94f441274f07f72627f445e989f75813a (patch)
treea17164d055d839419a8596fc77656284d64dc656 /dev-python/docker-py/docker-py-3.7.3.ebuild
parentdev-db/pgpool2: Cleanup 3.7.8, 4.0.3 (diff)
downloadgentoo-6522e7d94f441274f07f72627f445e989f75813a.tar.gz
gentoo-6522e7d94f441274f07f72627f445e989f75813a.tar.bz2
gentoo-6522e7d94f441274f07f72627f445e989f75813a.zip
dev-python/docker-py: Version bump to 3.7.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-python/docker-py/docker-py-3.7.3.ebuild')
-rw-r--r--dev-python/docker-py/docker-py-3.7.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/docker-py/docker-py-3.7.3.ebuild b/dev-python/docker-py/docker-py-3.7.3.ebuild
new file mode 100644
index 000000000000..2573b1681c68
--- /dev/null
+++ b/dev-python/docker-py/docker-py-3.7.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.4.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}