summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-04-16 11:01:11 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-04-16 11:01:11 +0200
commit0a1f37db21755243884a27c23b837409fe306b24 (patch)
treed084c1dcf0b524f8af5ec6ff5fbd7d8dec4939d9 /dev-python/docker-py
parentapp-shells/zsh-completions: Remove old (diff)
downloadgentoo-0a1f37db21755243884a27c23b837409fe306b24.tar.gz
gentoo-0a1f37db21755243884a27c23b837409fe306b24.tar.bz2
gentoo-0a1f37db21755243884a27c23b837409fe306b24.zip
dev-python/docker-py: Version bump to 3.7.1
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'dev-python/docker-py')
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-3.7.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index d602bc9f7390..6868bdb98947 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -5,3 +5,4 @@ DIST docker-py-3.5.0.tar.gz 209142 BLAKE2B 56e4400e1f67c870274eb2fdaf84edeac966a
DIST docker-py-3.5.1.tar.gz 209381 BLAKE2B de0992aff9af240eeb79b66f0f7ca11aca4132cbef0ca9796cfa778b0f44e2ebf83858d0e4df2b9dd813caa83e1c301829152362a6983e5ee96dd5806815ee6f SHA512 8e927794cd308e17fc75f3c6569026c9b9c9f44eb2aa1c191dcfc6d1aabc36bdd341795ba9a2243ae2a27c428868c9f45e8bfabd7c1c798f3f4c85b7855eda6d
DIST docker-py-3.6.0.tar.gz 213435 BLAKE2B 28301a508ef346373f8ac4033b697a71092c4162ba1be81bc69c513d1de700326a4e8ffcb1c015e20516aa1a09d31162d54182985eea3dc1dc23d6e79ef28fea SHA512 b32acb2585995c3c5bdef95ea4bbb6bcadba3b9fca81a3e637dc294b5dbd3823ee6c98236c4bb197373a96feafcaae665b9c64b805abd52e1ae27aa42079278d
DIST docker-py-3.7.0.tar.gz 220407 BLAKE2B 3ba217957ff8746fb399ba23e4513810ffd96a758bfc5eba908ab3c66eb0a9711d94e5d9f517c301602961a21490659628d0a3deec3a4286155a4f5469304a3b SHA512 444634a26d0ce7af4850f346286cdac7f2c597aa6ce349c6371dbaa670aa0bcc2fa192221783b2059750d682580e34fcc5e115aeda0884838bf966decf9d0070
+DIST docker-py-3.7.1.tar.gz 220882 BLAKE2B a7547d2989b3fc2dfc38dfffb909508b7a5b3f8ee6b0fc874a73d0cdfaa17fe28c971f5a226893a41d893e75b1b2e4c74da806996e85b097b3a85b2d8dadcfcb SHA512 0a89c5fc05423d913b1029390318d9cd4ca54a3b4df1e9a9f459e27fa114fd7b03047ff95f3ea2ef6bb2cb48c5f6fe712da11c940249d3b253aa3fe74b8b1c98
diff --git a/dev-python/docker-py/docker-py-3.7.1.ebuild b/dev-python/docker-py/docker-py-3.7.1.ebuild
new file mode 100644
index 000000000000..baf8b55a5049
--- /dev/null
+++ b/dev-python/docker-py/docker-py-3.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.4.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}