summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-04 12:55:53 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-04 12:55:53 +0200
commitcd2a88a5dc95289fdf3c5ebfb7642a261e1176b4 (patch)
treeb278a960de8edb4b206b9e82dc6b32c630d55079 /dev-python/docker-py
parentdev-python/django_polymorphic: Remove old (diff)
downloadgentoo-cd2a88a5dc95289fdf3c5ebfb7642a261e1176b4.tar.gz
gentoo-cd2a88a5dc95289fdf3c5ebfb7642a261e1176b4.tar.bz2
gentoo-cd2a88a5dc95289fdf3c5ebfb7642a261e1176b4.zip
dev-python/docker-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/docker-py')
-rw-r--r--dev-python/docker-py/Manifest3
-rw-r--r--dev-python/docker-py/docker-py-3.6.0.ebuild50
-rw-r--r--dev-python/docker-py/docker-py-3.7.1.ebuild50
-rw-r--r--dev-python/docker-py/docker-py-4.1.0.ebuild48
-rw-r--r--dev-python/docker-py/docker-py-4.2.0.ebuild48
5 files changed, 0 insertions, 199 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index d7b7ec741fac..4c8d9e63810d 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -1,4 +1 @@
-DIST docker-py-3.6.0.tar.gz 213435 BLAKE2B 28301a508ef346373f8ac4033b697a71092c4162ba1be81bc69c513d1de700326a4e8ffcb1c015e20516aa1a09d31162d54182985eea3dc1dc23d6e79ef28fea SHA512 b32acb2585995c3c5bdef95ea4bbb6bcadba3b9fca81a3e637dc294b5dbd3823ee6c98236c4bb197373a96feafcaae665b9c64b805abd52e1ae27aa42079278d
-DIST docker-py-3.7.1.tar.gz 220882 BLAKE2B a7547d2989b3fc2dfc38dfffb909508b7a5b3f8ee6b0fc874a73d0cdfaa17fe28c971f5a226893a41d893e75b1b2e4c74da806996e85b097b3a85b2d8dadcfcb SHA512 0a89c5fc05423d913b1029390318d9cd4ca54a3b4df1e9a9f459e27fa114fd7b03047ff95f3ea2ef6bb2cb48c5f6fe712da11c940249d3b253aa3fe74b8b1c98
-DIST docker-py-4.1.0.tar.gz 229336 BLAKE2B 8a2e0333e0e90399c0c4267c5b5205f3639077384e882e920a613e2d30d7ee915bdd549ec89a4c0e34646edbc6dea450ce63e45cf9cbc1efe0e26ff6ea5961db SHA512 25e236bd5b429846ed45f26a303af02bb679c526f45f188d8df74d79fcab116b41e52e3a85642babff94127ae977dab6cc93e53bb78aab7be038190e161d25be
DIST docker-py-4.2.0.tar.gz 234304 BLAKE2B 385f7fbfaabd4732a2f3bb074094b9f286ee9c6a543432f9a15fc6a78a595f44e4ddebcb3037ff1df54cb4b8d6aec40d8961fb4f62710a0a3245eb886d830c80 SHA512 df5a450355f11d580568ebb0e80abc967df35f2ae10ce83c4ece85e4cf3e97d9cd15e5f14a2d9a43650a844d9402a8d97370f6e5f615c186b12968379e52fa38
diff --git a/dev-python/docker-py/docker-py-3.6.0.ebuild b/dev-python/docker-py/docker-py-3.6.0.ebuild
deleted file mode 100644
index e56430129585..000000000000
--- a/dev-python/docker-py/docker-py-3.6.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Docker"
-HOMEPAGE="https://github.com/docker/docker-py"
-SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/docker-pycreds-0.3.0[${PYTHON_USEDEP}]
- !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.4.2[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/recommonmark[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die "docs failed to build"
- HTML_DOCS=( html/. )
- fi
-}
-
-python_test() {
- py.test tests/unit/ || die "tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/docker-py/docker-py-3.7.1.ebuild b/dev-python/docker-py/docker-py-3.7.1.ebuild
deleted file mode 100644
index 33d3165689a1..000000000000
--- a/dev-python/docker-py/docker-py-3.7.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Docker"
-HOMEPAGE="https://github.com/docker/docker-py"
-SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/docker-pycreds-0.4.0[${PYTHON_USEDEP}]
- !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.4.2[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/recommonmark[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die "docs failed to build"
- HTML_DOCS=( html/. )
- fi
-}
-
-python_test() {
- py.test tests/unit/ || die "tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/docker-py/docker-py-4.1.0.ebuild b/dev-python/docker-py/docker-py-4.1.0.ebuild
deleted file mode 100644
index c5a9478e00f5..000000000000
--- a/dev-python/docker-py/docker-py-4.1.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Docker"
-HOMEPAGE="https://github.com/docker/docker-py"
-SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- ${RDEPEND}
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.4.2[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/recommonmark[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die "docs failed to build"
- HTML_DOCS=( html/. )
- fi
-}
-
-python_test() {
- py.test tests/unit/ || die "tests failed under ${EPYTHON}"
-}
diff --git a/dev-python/docker-py/docker-py-4.2.0.ebuild b/dev-python/docker-py/docker-py-4.2.0.ebuild
deleted file mode 100644
index c5a9478e00f5..000000000000
--- a/dev-python/docker-py/docker-py-4.2.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Docker"
-HOMEPAGE="https://github.com/docker/docker-py"
-SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- ${RDEPEND}
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.4.2[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/recommonmark[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die "docs failed to build"
- HTML_DOCS=( html/. )
- fi
-}
-
-python_test() {
- py.test tests/unit/ || die "tests failed under ${EPYTHON}"
-}