summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-03-20 16:00:01 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-03-20 16:06:40 -0500
commit026f4ee66c2245bcd2a8f51365ab1e443f5b5fd3 (patch)
treebfbae2341d67fa88c91c021837e964c3043659be /dev-python/dockerpty/dockerpty-0.4.1.ebuild
parentmedia-libs/glfw: clean old (diff)
downloadgentoo-026f4ee66c2245bcd2a8f51365ab1e443f5b5fd3.tar.gz
gentoo-026f4ee66c2245bcd2a8f51365ab1e443f5b5fd3.tar.bz2
gentoo-026f4ee66c2245bcd2a8f51365ab1e443f5b5fd3.zip
dev-python/dockerpty: add version 0.4.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/dockerpty/dockerpty-0.4.1.ebuild')
-rw-r--r--dev-python/dockerpty/dockerpty-0.4.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dockerpty/dockerpty-0.4.1.ebuild b/dev-python/dockerpty/dockerpty-0.4.1.ebuild
new file mode 100644
index 000000000000..02e2d29db7bb
--- /dev/null
+++ b/dev-python/dockerpty/dockerpty-0.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python library to use the pseudo-tty of a docker container"
+HOMEPAGE="https://github.com/d11wtq/dockerpty"
+SRC_URI="https://github.com/d11wtq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/docker-py-0.7.0_rc2[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.5.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=">=dev-python/six-1.3.0[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}