summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 18:45:49 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 18:45:58 +0100
commitd680bf6ba9b5f573c41f93f87d7fd46ad84e5dd0 (patch)
tree2e0adb16ddfc25242b1267c06336ab17f953c06d /dev-python/doit-py/doit-py-0.4.0.ebuild
parentdev-python/singledispatch: Add more python targets (diff)
downloadgentoo-d680bf6ba9b5f573c41f93f87d7fd46ad84e5dd0.tar.gz
gentoo-d680bf6ba9b5f573c41f93f87d7fd46ad84e5dd0.tar.bz2
gentoo-d680bf6ba9b5f573c41f93f87d7fd46ad84e5dd0.zip
dev-python/doit-py: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/doit-py/doit-py-0.4.0.ebuild')
-rw-r--r--dev-python/doit-py/doit-py-0.4.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/doit-py/doit-py-0.4.0.ebuild b/dev-python/doit-py/doit-py-0.4.0.ebuild
new file mode 100644
index 000000000000..086f6e19046f
--- /dev/null
+++ b/dev-python/doit-py/doit-py-0.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="doit tasks for python stuff"
+HOMEPAGE="http://pythonhosted.org/doit-py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/singledispatch[${PYTHON_USEDEP}]
+ app-text/hunspell )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ dev-python/doit[${PYTHON_USEDEP}]
+ dev-python/configclass[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}