summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-07-17 02:01:17 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-07-16 21:17:07 -0400
commit15c29ed18b2895ba8c5d2fc4d65f2dfbd6c1abdb (patch)
treec22387a6c38ed487185be3c3187b7ef62fee5052 /dev-python/dominate/dominate-2.2.1.ebuild
parentdev-python/jaraco-collections: remove old (diff)
downloadgentoo-15c29ed18b2895ba8c5d2fc4d65f2dfbd6c1abdb.tar.gz
gentoo-15c29ed18b2895ba8c5d2fc4d65f2dfbd6c1abdb.tar.bz2
gentoo-15c29ed18b2895ba8c5d2fc4d65f2dfbd6c1abdb.zip
dev-python/dominate: bump to 2.2.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/dominate/dominate-2.2.1.ebuild')
-rw-r--r--dev-python/dominate/dominate-2.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/dominate/dominate-2.2.1.ebuild b/dev-python/dominate/dominate-2.2.1.ebuild
new file mode 100644
index 000000000000..94745def14f4
--- /dev/null
+++ b/dev-python/dominate/dominate-2.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="https://github.com/Knio/dominate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND=""
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}