summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-15 09:02:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-15 10:52:07 +0100
commit976cb29efb7b7eef6c9e0e4e2deecac2f6b09784 (patch)
treec7f4f33506cf81667be66f6ac807c9d7c93ffa93 /dev-python/easyprocess
parentdev-python/jupyter_server: Bump to 1.13.3 (diff)
downloadgentoo-976cb29efb7b7eef6c9e0e4e2deecac2f6b09784.tar.gz
gentoo-976cb29efb7b7eef6c9e0e4e2deecac2f6b09784.tar.bz2
gentoo-976cb29efb7b7eef6c9e0e4e2deecac2f6b09784.zip
dev-python/easyprocess: Bump to 1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/easyprocess')
-rw-r--r--dev-python/easyprocess/Manifest1
-rw-r--r--dev-python/easyprocess/easyprocess-1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/easyprocess/Manifest b/dev-python/easyprocess/Manifest
index 1c5ff6198419..affd7ce4fd82 100644
--- a/dev-python/easyprocess/Manifest
+++ b/dev-python/easyprocess/Manifest
@@ -1 +1,2 @@
DIST easyprocess-0.3.tar.gz 11310 BLAKE2B d26405863f213a94687d646f57aed98d0285bd57c0dfe9c40d2f49e5cfe46710e0435ff20eb1d697648e6fd1b63a38adf46a03f0fe970e35d44bfe3ad058d63f SHA512 3a10a02b28139c2d3d53134ac7842dcc7027c855e55b17747be1545cbf77cf86303531b595a54d92d7dc8133aee210388d25f3362b705ee554323c01d742d336
+DIST easyprocess-1.0.tar.gz 13757 BLAKE2B 40af585cc27a5b238d2688be6a55b39433fb8d3f62835ad64f93c5bd0fd98de8928796fbf262f6c390a08dc0e3b103bfb10adbf387a521c20e68e5615e4fee53 SHA512 d20c4b855403b5bc637ae4572563bd21d3bec7dcc083b06066020e1ad9ceb4645a2bde3575cbdc3e13607ad048c86d75fc7e7ef9c5367d99bb9556a1630f9cdd
diff --git a/dev-python/easyprocess/easyprocess-1.0.ebuild b/dev-python/easyprocess/easyprocess-1.0.ebuild
new file mode 100644
index 000000000000..f17744f48ed2
--- /dev/null
+++ b/dev-python/easyprocess/easyprocess-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use Python subprocess interface"
+HOMEPAGE="https://github.com/ponty/EasyProcess"
+SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/EasyProcess-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # looks like a problem within imagemagick itself
+ tests/test_fast/test_deadlock.py::test_has_imagemagick
+ # TODO
+ tests/test_fast/test_deadlock.py::test_deadlock_pipe
+)