summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:36:25 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-01 12:55:31 +0200
commita3c57615535b38811021a314ed13956ff3825524 (patch)
tree3730782f5e5640f9148b0a5da9390cc8af6b098d /dev-python/easyprocess
parentdev-python/entrypoint2: enable py3.11 (diff)
downloadgentoo-a3c57615535b38811021a314ed13956ff3825524.tar.gz
gentoo-a3c57615535b38811021a314ed13956ff3825524.tar.bz2
gentoo-a3c57615535b38811021a314ed13956ff3825524.zip
dev-python/easyprocess: enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/easyprocess')
-rw-r--r--dev-python/easyprocess/easyprocess-1.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/easyprocess/easyprocess-1.1-r1.ebuild b/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
new file mode 100644
index 000000000000..c3fa0cf4c6a2
--- /dev/null
+++ b/dev-python/easyprocess/easyprocess-1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Easy to use Python subprocess interface"
+HOMEPAGE="https://github.com/ponty/EasyProcess"
+SRC_URI="https://github.com/ponty/EasyProcess/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/EasyProcess-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # looks like a problem within imagemagick itself
+ tests/test_fast/test_deadlock.py::test_has_imagemagick
+ # TODO
+ tests/test_fast/test_deadlock.py::test_deadlock_pipe
+)