summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2017-01-29 05:55:19 +0000
committerGöktürk Yüksek <gokturk@gentoo.org>2017-02-06 16:13:44 -0500
commite9081ed3fc49c8dae02585968d4c811636920c53 (patch)
tree40c39e5a0477fb76219ed9f5745696b9da3fe285 /dev-python/elasticsearch-curator
parentapp-forensics/afl: Remove old versions (diff)
downloadgentoo-e9081ed3fc49c8dae02585968d4c811636920c53.tar.gz
gentoo-e9081ed3fc49c8dae02585968d4c811636920c53.tar.bz2
gentoo-e9081ed3fc49c8dae02585968d4c811636920c53.zip
dev-python/elasticsearch-curator: bump to 4.2.6
Diffstat (limited to 'dev-python/elasticsearch-curator')
-rw-r--r--dev-python/elasticsearch-curator/Manifest1
-rw-r--r--dev-python/elasticsearch-curator/elasticsearch-curator-4.2.6.ebuild120
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/elasticsearch-curator/Manifest b/dev-python/elasticsearch-curator/Manifest
index fda690dc0e8b..1c7dfe72de3a 100644
--- a/dev-python/elasticsearch-curator/Manifest
+++ b/dev-python/elasticsearch-curator/Manifest
@@ -2,3 +2,4 @@ DIST elasticsearch-2.4.0.tar.gz 27364449 SHA256 3ae01140ae7bcbb91436feef381fbed7
DIST elasticsearch-5.1.2.tar.gz 33299777 SHA256 74d752f9a8b46898d306ad169b72f328e17215c0909149e156a576089ef11c42 SHA512 1867626e8a87f11ed109e1325fd1d16c9e0af06ebe6a30c78ea679ab533ab377f5da8ea55af6871be33af226f02187a2aadd77e5e23c097dd24055be21e9d691 WHIRLPOOL 2e9df71c915343e2cc8ad82c59b877f41f5e093cbeba21f471c32cb51a195eccc6223bc48da48bb4af2e6bea9f2539f2e93b866963148f4ca2940ba4466e614e
DIST elasticsearch-curator-4.1.2.tar.gz 130194 SHA256 f4ccc0d49790e0f9390982cc2f0c69ad385361e7840050b6ecba4ef70fa64a0d SHA512 4a465c03baea6b708ce38bbaea8c94a288f91db39fba253a3123af68bce94b1253d22f0d9214fc449a97d55ad468f7f78bf14993c0f5cf18fcf91ebbe1ec57cb WHIRLPOOL 73f8b59f08a6746468336aaac9217a4e37ee15e0deeaf9711d7af79585dfe4e18402d6dceb3feafbafec3e2609dbcc7df983555529640e046336e0bb7421f0d3
DIST elasticsearch-curator-4.2.5.tar.gz 227607 SHA256 1a4869fcdbae062dd9777fece8265d5a493dc0e617f152b118955001604de7b8 SHA512 c43b45174098a33e68fedfd298c8377bf7541dafe4d6293311775325fd8ac3152f43fa0ea5beb1f8b459a3d0998167b2232564b2e11df6e1cff28afe0abc3dfc WHIRLPOOL f5176bfab80a8e7f05daf8634a6be984dcf4420615be773d58c74aa3060cb4b7c8052376653c28be7c2c6276251cc296929c35d4537aac46d600d7a0574a10c0
+DIST elasticsearch-curator-4.2.6.tar.gz 228342 SHA256 bebc7f6b53a4147e92004dd63d2349bb18170feed12b9219206d0d074b0643ae SHA512 e42d9f3c6122ba9cfc0bc90323f12d7ebf09902d04138472999b63fc59742f2f461b889dd98fca98f321d4975a3c05bc2aae5d211a774abd49b628ea318f5f64 WHIRLPOOL 63eed5c64f3a08f44d6feb8eb56b7698e8081a948b67daae91bb692d69e3ed1166c2fb867cb61f3f114eed74d05251b3aae68a8c475bf75ce318d53435e27b7e
diff --git a/dev-python/elasticsearch-curator/elasticsearch-curator-4.2.6.ebuild b/dev-python/elasticsearch-curator/elasticsearch-curator-4.2.6.ebuild
new file mode 100644
index 000000000000..60657434ee52
--- /dev/null
+++ b/dev-python/elasticsearch-curator/elasticsearch-curator-4.2.6.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_PN="curator"
+ES_VERSION="5.1.2"
+
+inherit distutils-r1
+
+DESCRIPTION="Tending time-series indices in Elasticsearch"
+HOMEPAGE="https://github.com/elasticsearch/curator"
+SRC_URI="https://github.com/elasticsearch/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-${ES_VERSION}.tar.gz )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/elasticsearch-py-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/elasticsearch-py-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-6.0[${PYTHON_USEDEP}]
+ >=dev-python/certifi-2017.1.23[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.8.3[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.9.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ virtual/jre:1.8
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/nosexcover[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# FEATURES="test -usersandbox" emerge dev-python/elasticsearch-curator
+python_test() {
+ ES="${WORKDIR}/elasticsearch-${ES_VERSION}"
+ ES_PORT="25123"
+ ES_INSTANCE="gentoo-es-curator-test"
+ ES_LOG="${ES}/logs/${ES_INSTANCE}.log"
+ PID="${ES}/elasticsearch.pid"
+
+ # run Elasticsearch instance on custom port
+ sed -i "s/#http.port: 9200/http.port: ${ES_PORT}/g; \
+ s/#cluster.name: my-application/cluster.name: ${ES_INSTANCE}/g" \
+ "${ES}/config/elasticsearch.yml" || die
+
+ # start local instance of elasticsearch
+ "${ES}/bin/elasticsearch" -d -p "${PID}" -Edefault.path.repo=/ || die
+
+ local i
+ local es_started=0
+ for i in {1..15}; do
+ grep -q "started" "${ES_LOG}" 2> /dev/null
+ if [[ $? -eq 0 ]]; then
+ einfo "Elasticsearch started"
+ es_started=1
+ eend 0
+ break
+ elif grep -q 'BindException\[Address already in use\]' "${ES_LOG}" 2>/dev/null; then
+ eend 1
+ eerror "Elasticsearch already running"
+ die "Cannot start Elasticsearch for tests"
+ else
+ einfo "Waiting for Elasticsearch"
+ eend 1
+ sleep 2
+ continue
+ fi
+ done
+
+ [[ $es_started -eq 0 ]] && die "Elasticsearch failed to start"
+
+ export TEST_ES_SERVER="localhost:${ES_PORT}"
+ esetup.py test || die
+
+ pkill -F ${PID}
+}
+
+python_prepare_all() {
+ # avoid downloading from net
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+
+ # remove test TestCLIFixFor687 as it is only to be run on older versions
+ # and the call to curator.get_version(global_client) sometimes
+ # fails with Connection refused
+ sed -e '122,205d' -i test/integration/test_delete_indices.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ cd docs || die
+ emake man $(usex doc html "")
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "For Python 3 support information please read: http://click.pocoo.org/3/python3/"
+ ewarn ""
+ ewarn "Example usage on Python 3:"
+ ewarn "export LC_ALL=en_US.UTF-8"
+ ewarn "export LANG=en_US.UTF-8"
+ ewarn "curator ..."
+}