summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-10 18:09:28 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-10 18:09:44 +0200
commite3a0d23f4ad40c56ab64367c541a368ce145c3ae (patch)
treed035629cfa397d6fc32b6ce05913a877b7e1fb16 /dev-python/enable/enable-4.5.1.ebuild
parentapp-emulation/libvirt: drop 1.2.15-r1 (diff)
downloadgentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.tar.gz
gentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.tar.bz2
gentoo-e3a0d23f4ad40c56ab64367c541a368ce145c3ae.zip
dev-python/enable: Add support for gcc-5
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=561836 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/enable/enable-4.5.1.ebuild')
-rw-r--r--dev-python/enable/enable-4.5.1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/enable/enable-4.5.1.ebuild b/dev-python/enable/enable-4.5.1.ebuild
index 31a0a802c754..300c03c337aa 100644
--- a/dev-python/enable/enable-4.5.1.ebuild
+++ b/dev-python/enable/enable-4.5.1.ebuild
@@ -41,7 +41,10 @@ DEPEND="${RDEPEND}
DISTUTILS_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}"/${PN}-4.4.1-swig.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.1-swig.patch
+ "${FILESDIR}"/${P}-gcc-5.patch
+ )
python_prepare_all() {
append-cflags -fno-strict-aliasing