summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-11-04 10:37:41 +0100
committerMatt Turner <mattst88@gentoo.org>2020-11-04 20:38:19 -0500
commit2a8cd7df6bfd7e53f682010332899a4ebabe7270 (patch)
tree56b0565555b60611f9449644908b04a7c2334df4 /dev-python/entrypoint2
parentdev-libs/simdjson-0.6.1: Version bump (diff)
downloadgentoo-2a8cd7df6bfd7e53f682010332899a4ebabe7270.tar.gz
gentoo-2a8cd7df6bfd7e53f682010332899a4ebabe7270.tar.bz2
gentoo-2a8cd7df6bfd7e53f682010332899a4ebabe7270.zip
dev-python/entrypoint2: version bump 0.2.3
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/18129 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/entrypoint2')
-rw-r--r--dev-python/entrypoint2/Manifest1
-rw-r--r--dev-python/entrypoint2/entrypoint2-0.2.3.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/entrypoint2/Manifest b/dev-python/entrypoint2/Manifest
index 68d47c783147..36f118d09d9e 100644
--- a/dev-python/entrypoint2/Manifest
+++ b/dev-python/entrypoint2/Manifest
@@ -1 +1,2 @@
DIST entrypoint2-0.2.1.tar.gz 11396 BLAKE2B ee462006f1fe4c80f707d00c2ef89fcf359b59853730786920ad931a099afafc808620ca16f0232e07a75c824b4b25ff50971c643f70087b89ab2ba6b7e13c1f SHA512 2273eda6cd8bf5a5e9fc5e8a657f837a88c8b617e384cdb6f6b62b3380e0b37d82af54dadd59a0ff82cd85cfdd61bb79d6c747621370f50e97c3796111baaaf6
+DIST entrypoint2-0.2.3.tar.gz 11542 BLAKE2B ef1ef511e02a3c5601d3147af241965fa78361a8cd070b5f0240f3842cdd49b3f93a32af4299568d201382c8c5a694ec7f85191c5880d489056744f59cbcd346 SHA512 c02ca02be9f25533c6a37a3aa372cdb75de8419349e279f7bd82369667a75943fc2fd0ba5afad49281d623f8ac4d6f97ffb2dbdb7b72b4cdc9afec80e763bed5
diff --git a/dev-python/entrypoint2/entrypoint2-0.2.3.ebuild b/dev-python/entrypoint2/entrypoint2-0.2.3.ebuild
new file mode 100644
index 000000000000..fc2e650b9d50
--- /dev/null
+++ b/dev-python/entrypoint2/entrypoint2-0.2.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use command-line interface for python modules"
+HOMEPAGE="https://github.com/ponty/entrypoint2"
+SRC_URI="https://github.com/ponty/entrypoint2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? (
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest