summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-27 09:36:52 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-27 10:26:12 +0100
commit9ef0bee8009b724b12f17f4f4046040fd7e79336 (patch)
treef4dc707955e3a68c027eba14ab28fe95066105ee /dev-python/enum34/enum34-1.1.2.ebuild
parentdev-python/enum34: Drop old (diff)
downloadgentoo-9ef0bee8009b724b12f17f4f4046040fd7e79336.tar.gz
gentoo-9ef0bee8009b724b12f17f4f4046040fd7e79336.tar.bz2
gentoo-9ef0bee8009b724b12f17f4f4046040fd7e79336.zip
dev-python/enum34: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/enum34/enum34-1.1.2.ebuild')
-rw-r--r--dev-python/enum34/enum34-1.1.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/enum34/enum34-1.1.2.ebuild b/dev-python/enum34/enum34-1.1.2.ebuild
new file mode 100644
index 000000000000..5cbdb610a974
--- /dev/null
+++ b/dev-python/enum34/enum34-1.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3.4 Enum backported"
+HOMEPAGE="https://pypi.python.org/pypi/enum34"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+python_test() {
+ "${PYTHON}" enum/test_enum.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local DOCS=( enum/doc/. enum/README )
+
+ distutils-r1_python_install_all
+}