summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-05-11 07:37:28 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-12 19:39:36 +0800
commit5e96ac7f819b5bcce7305ef851a4903a8cca27af (patch)
tree06a9473508f05da482c1098f74490d013f287aac /dev-python/enzyme/enzyme-9999.ebuild
parentdev-python/babelfish: remove old (diff)
downloadgentoo-5e96ac7f819b5bcce7305ef851a4903a8cca27af.tar.gz
gentoo-5e96ac7f819b5bcce7305ef851a4903a8cca27af.tar.bz2
gentoo-5e96ac7f819b5bcce7305ef851a4903a8cca27af.zip
dev-python/enzyme: revbump to 0.4.1-r1
Bump EAPI to 6, add missing and fix existing deps. Update 9999 ebuild accordingly. Package-Manager: portage-2.2.28 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/enzyme/enzyme-9999.ebuild')
-rw-r--r--dev-python/enzyme/enzyme-9999.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/dev-python/enzyme/enzyme-9999.ebuild b/dev-python/enzyme/enzyme-9999.ebuild
index 51ac2e149435..9a62290a9beb 100644
--- a/dev-python/enzyme/enzyme-9999.ebuild
+++ b/dev-python/enzyme/enzyme-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-EGIT_REPO_URI="https://github.com/Diaoul/enzyme.git"
-inherit distutils-r1 git-2
+inherit distutils-r1 git-r3
DESCRIPTION="Python video metadata parser"
HOMEPAGE="https://github.com/Diaoul/enzyme https://pypi.python.org/pypi/enzyme"
+EGIT_REPO_URI="git://github.com/Diaoul/${PN}.git"
SRC_URI="test? ( http://downloads.sourceforge.net/project/matroska/test_files/matroska_test_w1_1.zip )"
LICENSE="Apache-2.0"
@@ -18,15 +18,20 @@ SLOT="0"
KEYWORDS=""
IUSE="test"
-RDEPEND=""
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
- dev-python/requests[${PYTHON_USEDEP}]
+ app-arch/unzip
dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
)
- dev-python/setuptools[${PYTHON_USEDEP}]
"
+src_unpack() {
+ default_src_unpack
+ git-r3_src_unpack
+}
+
python_prepare_all() {
if use test; then
mkdir enzyme/tests/test_{parsers,mkv} || die