summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-06 14:51:59 +0200
committerZac Medico <zmedico@gentoo.org>2020-10-06 09:56:51 -0700
commitd3a73f0562667892c871933c8d964277b5d140a7 (patch)
tree03feae363d699992a2420b6d9dc042ae36858281 /dev-python/eradicate
parentsci-mathematics/wxmaxima: bump to 20.09.0 (diff)
downloadgentoo-d3a73f0562667892c871933c8d964277b5d140a7.tar.gz
gentoo-d3a73f0562667892c871933c8d964277b5d140a7.tar.bz2
gentoo-d3a73f0562667892c871933c8d964277b5d140a7.zip
dev-python/eradicate: bump to 2.0, add tests and Py3.9 support
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/eradicate')
-rw-r--r--dev-python/eradicate/Manifest1
-rw-r--r--dev-python/eradicate/eradicate-2.0.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/eradicate/Manifest b/dev-python/eradicate/Manifest
index 3f5fe29c3bab..42769ea1699c 100644
--- a/dev-python/eradicate/Manifest
+++ b/dev-python/eradicate/Manifest
@@ -1 +1,2 @@
DIST eradicate-1.0.tar.gz 4644 BLAKE2B 428577e57fbe9c04074bded6b588cf7f8fd795084332cf3515c0a99f317a64bf195c7e0d5145e6e8a2ba10f2e524f874505844d9cf8c098b528fa213d3dd8a00 SHA512 ed27e73ca25ec76418e06eca80b09cad6386a4cf0b48927de30b0fa6edb8bef2a03312c494bba4bdc6f41b0e2f508a4d3573ff3471dd78aece2c92c46ef8f41b
+DIST eradicate-2.0.0.tar.gz 8390 BLAKE2B 22dced2414622138655be80d1c10b746519d313959c7620cb54c4dc27247b0c29b7607c54934fe1dc379bec2cb729213b7ffb1d27f3f7f9b9a9d186aa9402674 SHA512 947a3890ccb1dbb52e73b37e632ae5ba1eff732d9d0b0dc127fa8dc908412e864fcda3203274d5eb1645b22f6e97a90ebb13cd4363a2360d6591475d909bdb96
diff --git a/dev-python/eradicate/eradicate-2.0.0.ebuild b/dev-python/eradicate/eradicate-2.0.0.ebuild
new file mode 100644
index 000000000000..ce8aeaeca5b2
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="https://github.com/myint/eradicate"
+# TODO: revert to PyPI tarball once it includes tests
+# https://github.com/myint/eradicate/pull/28
+SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest