summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-17 15:08:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-17 15:49:42 +0100
commited2fb42d47c46e5072a251dff48fa236cb248615 (patch)
tree3b9ee76f8fdad629fa3d5ed18dc731135751eeae /dev-python/errorhandler
parentapp-crypt/gnupg: Don't use underscores in new USE flag (QA fix) (diff)
downloadgentoo-ed2fb42d47c46e5072a251dff48fa236cb248615.tar.gz
gentoo-ed2fb42d47c46e5072a251dff48fa236cb248615.tar.bz2
gentoo-ed2fb42d47c46e5072a251dff48fa236cb248615.zip
dev-python/errorhandler: Port up to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/errorhandler')
-rw-r--r--dev-python/errorhandler/errorhandler-2.0.1.ebuild28
1 files changed, 4 insertions, 24 deletions
diff --git a/dev-python/errorhandler/errorhandler-2.0.1.ebuild b/dev-python/errorhandler/errorhandler-2.0.1.ebuild
index 93ae7ba108e0..f757ff8fef46 100644
--- a/dev-python/errorhandler/errorhandler-2.0.1.ebuild
+++ b/dev-python/errorhandler/errorhandler-2.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -12,32 +12,12 @@ HOMEPAGE="https://pypi.org/project/errorhandler/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
LICENSE="MIT"
SLOT="0"
RDEPEND=""
DEPEND="
- dev-python/pkginfo[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.1-no-intersphinx.patch
-)
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
+ dev-python/pkginfo[${PYTHON_USEDEP}]"
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
+distutils_enable_sphinx docs
+distutils_enable_tests nose