summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-05 09:24:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-05 09:24:24 +0200
commit296be14c20fdda6dcdcc01046b40f25897eb262a (patch)
tree882740ebfa8f0aefb0f7a9c1bb913e3b614b2831 /dev-python/exdown
parentdev-python/greenlet: Modernize running unittests (diff)
downloadgentoo-296be14c20fdda6dcdcc01046b40f25897eb262a.tar.gz
gentoo-296be14c20fdda6dcdcc01046b40f25897eb262a.tar.bz2
gentoo-296be14c20fdda6dcdcc01046b40f25897eb262a.zip
dev-python/exdown: Bump to 0.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/exdown')
-rw-r--r--dev-python/exdown/Manifest1
-rw-r--r--dev-python/exdown/exdown-0.8.8.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/exdown/Manifest b/dev-python/exdown/Manifest
index 92b9f5747a03..d7c1439034f5 100644
--- a/dev-python/exdown/Manifest
+++ b/dev-python/exdown/Manifest
@@ -1 +1,2 @@
DIST exdown-0.8.6.tar.gz 5480 BLAKE2B fe383a2092691afdb2a3fd8cfeffb78f62b23bd4dc8f8d5365102084acc8670c9f2bc3e4a0ade95a50ceffc5cc142c39dbd3e505678a238d6f39b82f6553071a SHA512 28cd68ed99d24c79a7764f7603242f2b1426f119864d39424b1326cecc5bc922ed610133099e7d03d384c485f4f67d1fefcaadee4e1f69ac8ece08136eb858e9
+DIST exdown-0.8.8.tar.gz 5523 BLAKE2B b53f23ebf133ad75973298b9b98c3f85f63802a9a302e92dda1446f0d686ba4eecd4fa72056d331b6e6caca5e066ec032a31fbfa3e74c1dba39ed007cf116480 SHA512 f5ef32b15720091c459110d6c9644b8dfcc84f6fd117f8433380704e93848cac0c9a3709d879bc42561474dd46b2035bc2be2f7e0bb5207a40ceb26ce4577b4a
diff --git a/dev-python/exdown/exdown-0.8.8.ebuild b/dev-python/exdown/exdown-0.8.8.ebuild
new file mode 100644
index 000000000000..d8894682f3ed
--- /dev/null
+++ b/dev-python/exdown/exdown-0.8.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/exdown"
+SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7)
+"
+
+distutils_enable_tests pytest