summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-03 10:03:43 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-03 11:26:06 +0200
commitec2fc2782323bca475342a9c25e5495fcff473d1 (patch)
tree66e7bce5aa5edc66a4b55aaca41129401b6ea73a /dev-python/execnet
parentdev-python/bleach: Clean old versions up (diff)
downloadgentoo-ec2fc2782323bca475342a9c25e5495fcff473d1.tar.gz
gentoo-ec2fc2782323bca475342a9c25e5495fcff473d1.tar.bz2
gentoo-ec2fc2782323bca475342a9c25e5495fcff473d1.zip
dev-python/execnet: Clean old versions up
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest1
-rw-r--r--dev-python/execnet/execnet-1.2.0-r2.ebuild48
-rw-r--r--dev-python/execnet/files/1.2.0-tests.patch115
3 files changed, 0 insertions, 164 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index fdf1a65c2184..aa51fef73b9d 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1,2 +1 @@
-DIST execnet-1.2.0.tar.gz 163876 SHA256 951714caa0ae80237f4ffc1f08450e9e2e5f8f902beaf1ad294020875d6f8c2c SHA512 bf4eb1c07832628863f3d315510628343bc4504050311a277a86100a825df8ed5f6b65f58db28ea6733f3886b6007eae7fd33586721374f9ffb3687e9b95d5c4 WHIRLPOOL 898d9427d55e316f2cdfe06d8dadd0f40d8d2374802b419c9b7aac279eed36919f8dc0084c9c253b3b3d75e9dd50ec2748ef2227e803bf900d7d8b0d5395c45e
DIST execnet-1.4.1.tar.gz 171041 SHA256 f66dd4a7519725a1b7e14ad9ae7d3df8e09b2da88062386e08e941cafc0ef3e6 SHA512 e8c0c32e873f8585ff4d4da3b9cbd40046479370f5653f67a98c9029d4535a619731d1b825332fe4af4dc5ebc9ab11ee879ef45df07f08943b1e1685f2255790 WHIRLPOOL 487c31617b78e4eeed9dc75ae8f01ade33aad35f7547677ec007b688071dd56e69c4f4b92cf9355dee7cea97bf6eac09f508099f104cf52d6c9fe3860e4fd3c9
diff --git a/dev-python/execnet/execnet-1.2.0-r2.ebuild b/dev-python/execnet/execnet-1.2.0-r2.ebuild
deleted file mode 100644
index ac4cc1275ea5..000000000000
--- a/dev-python/execnet/execnet-1.2.0-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="http://codespeak.net/execnet/ https://pypi.python.org/pypi/execnet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RDEPEND=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
-
-python_prepare_all() {
- # Remove doctest that access an i'net site
- rm doc/example/test_info.txt || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- # https://bitbucket.org/hpk42/execnet/issue/10
- unset PYTHONDONTWRITEBYTECODE
- py.test testing || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/execnet/files/1.2.0-tests.patch b/dev-python/execnet/files/1.2.0-tests.patch
deleted file mode 100644
index 13bed5d59605..000000000000
--- a/dev-python/execnet/files/1.2.0-tests.patch
+++ /dev/null
@@ -1,115 +0,0 @@
-# HG changeset patch
-# User holger krekel <holger@merlinux.eu>
-# Date 1412585605 -7200
-# Node ID c9303c302995a4fb844553d4977c55abc72e2020
-# Parent 47ff3652b0aed191f7bafc741c211d1415f65224
-fix issue35: adapt some doctests, fix some channel tests for py3.
-Also modernize tox.ini a bit.
---rebased
-diff -ur execnet-1.2.0.orig/doc/example/test_group.txt execnet-1.2.0/doc/example/test_group.txt
---- doc/example/test_group.txt 2014-01-29 19:50:22.000000000 +0800
-+++ doc/example/test_group.txt 2014-10-10 19:51:00.108828123 +0800
-@@ -14,7 +14,7 @@
- >>> group
- <Group ['gw0', 'gw1']>
- >>> list(group)
-- [<PopenGateway id='gw0' receive-live, 0 active channels>, <PopenGateway id='gw1' receive-live, 0 active channels>]
-+ [<Gateway id='gw0' receive-live, thread model, 0 active channels>, <Gateway id='gw1' receive-live, thread model, 0 active channels>]
- >>> 'gw0' in group and 'gw1' in group
- True
- >>> group['gw0'] == group[0]
-@@ -37,7 +37,7 @@
- >>> gw = group.makegateway("popen//id=sub1")
- >>> assert gw.id == "sub1"
- >>> group['sub1']
-- <PopenGateway id='sub1' receive-live, 0 active channels>
-+ <Gateway id='sub1' receive-live, thread model, 0 active channels>
-
- Getting (auto) IDs before instantiation
- ------------------------------------------------------
-diff -ur execnet-1.2.0.orig/doc/example/test_proxy.txt execnet-1.2.0/doc/example/test_proxy.txt
---- doc/example/test_proxy.txt 2014-01-29 19:50:22.000000000 +0800
-+++ doc/example/test_proxy.txt 2014-10-10 19:16:50.380156509 +0800
-@@ -18,10 +18,10 @@
- >>> group.defaultspec = 'popen//via=master'
- >>> master = group.makegateway('popen//id=master')
- >>> master
-- <Gateway id='master' receive-live, 0 active channels>
-+ <Gateway id='master' receive-live, thread model, 0 active channels>
- >>> slave = group.makegateway()
- >>> slave
-- <Gateway id='gw0' receive-live, 0 active channels>
-+ <Gateway id='gw0' receive-live, thread model, 0 active channels>
- >>> group
- <Group ['master', 'gw0']>
-
-diff -ur execnet-1.2.0.orig/testing/test_channel.py execnet-1.2.0/testing/test_channel.py
---- testing/test_channel.py 2014-01-29 19:50:22.000000000 +0800
-+++ testing/test_channel.py 2014-10-10 19:21:00.943955387 +0800
-@@ -68,25 +68,19 @@
-
- def test_channel_error_reporting(self, gw):
- channel = gw.remote_exec('def foo():\n return foobar()\nfoo()\n')
-- try:
-- channel.receive()
-- except channel.RemoteError:
-- e = sys.exc_info()[1]
-- assert str(e).startswith('Traceback (most recent call last):')
-- assert str(e).find('NameError: global name \'foobar\' '
-- 'is not defined') > -1
-- else:
-- pytest.fail('No exception raised')
-+ excinfo = pytest.raises(channel.RemoteError, channel.receive)
-+ msg = str(excinfo.value)
-+ assert msg.startswith('Traceback (most recent call last):')
-+ assert "NameError" in msg
-+ assert "foobar" in msg
-
- def test_channel_syntax_error(self, gw):
- # missing colon
- channel = gw.remote_exec('def foo()\n return 1\nfoo()\n')
-- try:
-- channel.receive()
-- except channel.RemoteError:
-- e = sys.exc_info()[1]
-- assert str(e).startswith('Traceback (most recent call last):')
-- assert str(e).find('SyntaxError') > -1
-+ excinfo = pytest.raises(channel.RemoteError, channel.receive)
-+ msg = str(excinfo.value)
-+ assert msg.startswith('Traceback (most recent call last):')
-+ assert "SyntaxError" in msg
-
- def test_channel_iter(self, gw):
- channel = gw.remote_exec("""
-diff -ur execnet-1.2.0.orig/tox.ini execnet-1.2.0/tox.ini
---- tox.ini 2014-01-29 19:50:22.000000000 +0800
-+++ tox.ini 2014-10-10 20:14:22.806301771 +0800
-@@ -1,16 +1,11 @@
- [tox]
--envlist=py26,py27,py32,py33,pypy,flakes
--distshare={homedir}/.tox/distshare
--
--[tox:hudson]
--distshare={toxworkdir}/distshare
--sdistsrc={distshare}/execnet-*
-+envlist=py26,py27,py33,py34,pypy,flakes
-
- [testenv]
- changedir=testing
- deps=pytest
- pytest-timeout
--commands=py.test -rsfxX --junitxml={envlogdir}/junit-{envname}.xml []
-+commands=py.test -rsfxX {posargs}
-
- [testenv:flakes]
- changedir=
-@@ -26,8 +21,7 @@
- deps=sphinx
- pytest
- commands=
-- py.test \
-- -rsfxX -v --junitxml={envlogdir}/junit-{envname}.xml check_sphinx.py
-+ py.test -rsfxX -v check_sphinx.py
-
- [pytest]
- timeout = 20