summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-05-28 10:25:48 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-05-28 10:25:48 -0500
commitcfe0bd4f1234a134c168811aca6087d49f27e851 (patch)
tree9e972b8d45e3f2f7713814d3aa7b6cea94b93d31 /dev-python/extras/extras-1.0.0.ebuild
parentdev-python/expects: remove version 0.8.0_rc4 (diff)
downloadgentoo-cfe0bd4f1234a134c168811aca6087d49f27e851.tar.gz
gentoo-cfe0bd4f1234a134c168811aca6087d49f27e851.tar.bz2
gentoo-cfe0bd4f1234a134c168811aca6087d49f27e851.zip
dev-python/extras: add version 1.0.0
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/extras/extras-1.0.0.ebuild')
-rw-r--r--dev-python/extras/extras-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/extras/extras-1.0.0.ebuild b/dev-python/extras/extras-1.0.0.ebuild
new file mode 100644
index 000000000000..3141f3b76caf
--- /dev/null
+++ b/dev-python/extras/extras-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful extra bits for Python that should be in the standard library"
+HOMEPAGE="https://github.com/testing-cabal/extras/ https://pypi.python.org/pypi/extras/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/testtools[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" ${PN}/tests/test_extras.py || die
+}