summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-11-25 15:13:52 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-11-25 15:18:11 -0500
commit0e171cc6223b6050bb43aab5c8ea093d67d9156a (patch)
treeb82569bbfd2332d7cd3b71faccd8fa44e21ff31d /dev-python/fido2
parentapp-crypt/yubikey-manager: adjust the fido2 dep version range (diff)
downloadgentoo-0e171cc6223b6050bb43aab5c8ea093d67d9156a.tar.gz
gentoo-0e171cc6223b6050bb43aab5c8ea093d67d9156a.tar.bz2
gentoo-0e171cc6223b6050bb43aab5c8ea093d67d9156a.zip
dev-python/fido2: bump to 0.8.1
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-0.8.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 54a3de6ec628..694eece0c15f 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -5,3 +5,4 @@ DIST fido2-0.6.0.tar.gz 163137 BLAKE2B 3a30d4267a1aae00eac8fa8c05065163f992b7289
DIST fido2-0.7.0.tar.gz 171787 BLAKE2B 6458a606ecbbd22ac7c49b2e32b46e43c0ca184645fff4c54e0204f044a415db05b3e7187b6138e4d1b67dad9ed5faf3eb561b11b391b5105bac4299481bd95d SHA512 65fdaeeb1932873fb2ae86257182eb6098d6bf4ce5ed45336327bd3e9040eddccd7f7559ece58d9bdcbfe8c98c2eb8646069556a6d00035fef5eade4907a45d8
DIST fido2-0.7.1.tar.gz 176790 BLAKE2B d6e800b750902ad26ea6fc0634b37215ac57a65c18d0139b38263d7b97fdf0aaa41070abd5da35891a0dee0c788e43cc7c3bf47e8c1328e292352612ad719c9b SHA512 07024a4076d88bd9ec5d5dbfd924c88e314906668444d96aa9177c373309e90e33c18fd5313943fd83eb28b6d40f0c16a8f64c5d9a2aa50f2fc5115c1967ae3a
DIST fido2-0.7.3.tar.gz 188262 BLAKE2B c1d832229ce741be3b81e4cded65b77e57c008aaba8ccbdf640bae1c27f4d86f2c0ce7ffc83405e3693646a8f2868030619c958ecbaa58a6a6328ece2cf6d3de SHA512 715779ecc9dba19de0e45df13d018e7dd223f20f5662860874aa8aa6f811c1df71c07656d21b49a4b6f14a149134d8af6bac076a7f71cb7392ca2fef70b173e1
+DIST fido2-0.8.1.tar.gz 201198 BLAKE2B 33411dd05d7f513445afa8a6fc4bb90f3989a655fa05d2ba9da411aa7eea3b30ffa253fae6586f76c416115e5bec90f6f120472a49a0acfbd91020d2cba8f74d SHA512 fc0753ea694f2170d529129764cd9f9c5439cd2f467e4f384d7a698266ee8391a5c9c7c6e51d2dc2a99b93fca1c7d5288d5236e302672a87b8ca7704f328c0b5
diff --git a/dev-python/fido2/fido2-0.8.1.ebuild b/dev-python/fido2/fido2-0.8.1.ebuild
new file mode 100644
index 000000000000..311a481c34f0
--- /dev/null
+++ b/dev-python/fido2/fido2-0.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/pyfakefs-3.4[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}