summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2021-03-08 21:32:17 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2021-03-14 15:54:54 -0400
commitbc4a4f3184938656366076d1c8db2289c8c4c857 (patch)
tree4790ea1b8f3942ebc0775c0fbddf7051be44f14c /dev-python/fido2
parentmedia-fonts/cascadia-code: Version bump 2102.25 (diff)
downloadgentoo-bc4a4f3184938656366076d1c8db2289c8c4c857.tar.gz
gentoo-bc4a4f3184938656366076d1c8db2289c8c4c857.tar.bz2
gentoo-bc4a4f3184938656366076d1c8db2289c8c4c857.zip
dev-python/fido2: bump to 0.9.1 and introduce subslots
The subslots represent the first version that introduces backward-incompatible changes to the API, denoted by "{major}.{minor}". Consumers should mainly bind on a specific subslot instead of ':=' since this is unlike soname and recompilation won't fix things in most cases. Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-0.9.1.ebuild53
-rw-r--r--dev-python/fido2/metadata.xml8
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index 4723eedf6a0e..285ab9341027 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,2 +1,3 @@
DIST fido2-0.7.3.tar.gz 188262 BLAKE2B c1d832229ce741be3b81e4cded65b77e57c008aaba8ccbdf640bae1c27f4d86f2c0ce7ffc83405e3693646a8f2868030619c958ecbaa58a6a6328ece2cf6d3de SHA512 715779ecc9dba19de0e45df13d018e7dd223f20f5662860874aa8aa6f811c1df71c07656d21b49a4b6f14a149134d8af6bac076a7f71cb7392ca2fef70b173e1
DIST fido2-0.8.1.tar.gz 201198 BLAKE2B 33411dd05d7f513445afa8a6fc4bb90f3989a655fa05d2ba9da411aa7eea3b30ffa253fae6586f76c416115e5bec90f6f120472a49a0acfbd91020d2cba8f74d SHA512 fc0753ea694f2170d529129764cd9f9c5439cd2f467e4f384d7a698266ee8391a5c9c7c6e51d2dc2a99b93fca1c7d5288d5236e302672a87b8ca7704f328c0b5
+DIST fido2-0.9.1.tar.gz 206395 BLAKE2B 9a9b5d0dd808de896c91aa605540a1968aab7ae543336521d4a206f27bcf836c57e88aa6cdd0bacf71db8d16a0f94c2f9c16b16ca415363fd0b5e145a448ec18 SHA512 cde8c247fe0875129a890866ab76d40b2bd6feee86ff1ccb4b9ec5e6dc037e569fc8d969b51a456b5e66c6f7c67e18d14c3917375d5de85bbe7da5af3254f797
diff --git a/dev-python/fido2/fido2-0.9.1.ebuild b/dev-python/fido2/fido2-0.9.1.ebuild
new file mode 100644
index 000000000000..446d15dd1580
--- /dev/null
+++ b/dev-python/fido2/fido2-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0/0.9" # Bumped every time a backwards-incompatible version is released
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+RESTRICT="test" # Tests require <dev-python/mock-4
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# Disable tests, <dev-python/mock-4 doesn't exist
+# DEPEND="${DEPEND}
+# test? (
+# ${RDEPEND}
+# <dev-python/mock-4[${PYTHON_USEDEP}]
+# >=dev-python/pyfakefs-3.4[${PYTHON_USEDEP}]
+# )
+# "
+#
+# When tests are available again, remember to add a custom
+# test phase that runs 'python -m unittest discover -v'
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}
diff --git a/dev-python/fido2/metadata.xml b/dev-python/fido2/metadata.xml
index 3ebed6d78bfc..9bc3de4b0261 100644
--- a/dev-python/fido2/metadata.xml
+++ b/dev-python/fido2/metadata.xml
@@ -10,6 +10,14 @@
device over USB as well as verifying attestation and assertion
signatures.
</longdescription>
+ <slots>
+ <subslots>
+ Reflects the versions that introduce backwards
+ incompatible changes. Do not bind with ':=',
+ unless you are absolutely sure. In most cases, you
+ should bind to a specific subslot.
+ </subslots>
+ </slots>
<stabilize-allarches/>
<upstream>
<remote-id type="github">Yubico/python-fido2</remote-id>