summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-23 09:59:44 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 11:35:49 +0100
commitf66d884e8fcecca96eb0b243ffc08930773489ea (patch)
treef134f145978580b5f07a2ea7a63a299d6c6fc38d /dev-python/filelock/filelock-3.0.12.ebuild
parentdev-python/pytest-forked: Bump to 1.1.3, py3.8 (diff)
downloadgentoo-f66d884e8fcecca96eb0b243ffc08930773489ea.tar.gz
gentoo-f66d884e8fcecca96eb0b243ffc08930773489ea.tar.bz2
gentoo-f66d884e8fcecca96eb0b243ffc08930773489ea.zip
dev-python/filelock: Bump to 3.0.12, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock/filelock-3.0.12.ebuild')
-rw-r--r--dev-python/filelock/filelock-3.0.12.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/filelock/filelock-3.0.12.ebuild b/dev-python/filelock/filelock-3.0.12.ebuild
new file mode 100644
index 000000000000..ff9f692b30b8
--- /dev/null
+++ b/dev-python/filelock/filelock-3.0.12.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="https://github.com/benediktschmitt/py-filelock
+ https://pypi.org/project/filelock/"
+SRC_URI="https://github.com/benediktschmitt/py-filelock/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest