summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-11-18 20:36:05 +0100
committerMichał Górny <mgorny@gentoo.org>2018-11-18 22:03:18 +0100
commit8227eaa7218ea5bc784ef5b38cf82e0bc6afe636 (patch)
tree04b58b8d929dcc024b65b527571ce93ab0b022b1 /dev-python/filelock
parentdev-lang/gnat-gpl: Add some profile definitions from 2017 (diff)
downloadgentoo-8227eaa7218ea5bc784ef5b38cf82e0bc6afe636.tar.gz
gentoo-8227eaa7218ea5bc784ef5b38cf82e0bc6afe636.tar.bz2
gentoo-8227eaa7218ea5bc784ef5b38cf82e0bc6afe636.zip
dev-python/filelock: New package, dep of dev-python/tox
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/filelock-3.0.10.ebuild34
-rw-r--r--dev-python/filelock/metadata.xml11
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/filelock/filelock-3.0.10.ebuild b/dev-python/filelock/filelock-3.0.10.ebuild
new file mode 100644
index 000000000000..04e239ae7c4e
--- /dev/null
+++ b/dev-python/filelock/filelock-3.0.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="https://github.com/benediktschmitt/py-filelock
+ https://pypi.org/project/filelock/"
+SRC_URI="https://github.com/benediktschmitt/py-filelock/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # test_del is relying on CPython behavior, so it breaks PyPy
+ # (and it's not very valuable anyway)
+ sed -i -e '/test_del/i\ \ \ \ @unittest.skipIf(hasattr(sys, "pypy_version_info"), "del() does not trigger GC on PyPy")' test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" test.py -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/filelock/metadata.xml b/dev-python/filelock/metadata.xml
new file mode 100644
index 000000000000..8684444c6ace
--- /dev/null
+++ b/dev-python/filelock/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">filelock</remote-id>
+ <remote-id type="github">benediktschmitt/py-filelock</remote-id>
+ </upstream>
+</pkgmetadata>