summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-10-13 15:14:08 -0700
committerZac Medico <zmedico@gentoo.org>2018-10-13 15:35:18 -0700
commit4ce78528031239524af920edfbacfca8a846e8e0 (patch)
tree6ee3e96756162317670179fa94feeafe3f46a1f1 /dev-python/flake8-import-order/flake8-import-order-0.18.ebuild
parentdev-python/pylama: new package (diff)
downloadgentoo-4ce78528031239524af920edfbacfca8a846e8e0.tar.gz
gentoo-4ce78528031239524af920edfbacfca8a846e8e0.tar.bz2
gentoo-4ce78528031239524af920edfbacfca8a846e8e0.zip
dev-python/flake8-import-order: new package
Signed-off-by: Zac Medico <zmedico@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/flake8-import-order/flake8-import-order-0.18.ebuild')
-rw-r--r--dev-python/flake8-import-order/flake8-import-order-0.18.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/flake8-import-order/flake8-import-order-0.18.ebuild b/dev-python/flake8-import-order/flake8-import-order-0.18.ebuild
new file mode 100644
index 000000000000..ffb5da6d0c94
--- /dev/null
+++ b/dev-python/flake8-import-order/flake8-import-order-0.18.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Flake8 plugin that checks import order against various Python Style Guides"
+HOMEPAGE="https://github.com/PyCQA/flake8-import-order"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v tests || die "tests failed with ${EPYTHON}"
+}