summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-06 23:29:48 +0000
committerSam James <sam@gentoo.org>2021-06-06 23:53:25 +0000
commitcd2b50b78ce498bc3034aca48c4f1e4450c950cd (patch)
tree35291691e0cd3857d8d43699ad5c15805928806b /dev-python/flake8-polyfill
parentdev-perl/Inline-Python: add Python 3.9 (diff)
downloadgentoo-cd2b50b78ce498bc3034aca48c4f1e4450c950cd.tar.gz
gentoo-cd2b50b78ce498bc3034aca48c4f1e4450c950cd.tar.bz2
gentoo-cd2b50b78ce498bc3034aca48c4f1e4450c950cd.zip
dev-python/flake8-polyfill: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/flake8-polyfill')
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
index 3a432d6f9643..da199eabc872 100644
--- a/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
DESCRIPTION="Polyfill package for Flake8 plugins"
@@ -18,11 +18,10 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
+DEPEND="
+ test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pycodestyle[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)"
distutils_enable_tests pytest