summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 17:20:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 17:37:41 +0200
commit291212127016ccfe8e54228fdb8dc6254660da10 (patch)
treedbc9c127ade33085b542b342d9dfb917467c7c84 /dev-python/flaky/flaky-3.7.0-r1.ebuild
parentdev-python/pbr: Remove python2 (diff)
downloadgentoo-291212127016ccfe8e54228fdb8dc6254660da10.tar.gz
gentoo-291212127016ccfe8e54228fdb8dc6254660da10.tar.bz2
gentoo-291212127016ccfe8e54228fdb8dc6254660da10.zip
dev-python/flaky: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flaky/flaky-3.7.0-r1.ebuild')
-rw-r--r--dev-python/flaky/flaky-3.7.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/flaky/flaky-3.7.0-r1.ebuild b/dev-python/flaky/flaky-3.7.0-r1.ebuild
new file mode 100644
index 000000000000..632402ee89cd
--- /dev/null
+++ b/dev-python/flaky/flaky-3.7.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ pytest -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ pytest -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ pytest --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}