summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 00:49:27 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 00:50:42 +0100
commited43198f7d94f997d270f4f0fac5cb0084444e3a (patch)
tree2fc7e87087ba76bed202e9bfbd56ff5fe8df3295 /dev-python/flaky
parentdev-python/unittest-mixins: Fix remaining MissingTestRestrict (diff)
downloadgentoo-ed43198f7d94f997d270f4f0fac5cb0084444e3a.tar.gz
gentoo-ed43198f7d94f997d270f4f0fac5cb0084444e3a.tar.bz2
gentoo-ed43198f7d94f997d270f4f0fac5cb0084444e3a.zip
dev-python/flaky: Bump to 3.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flaky')
-rw-r--r--dev-python/flaky/Manifest1
-rw-r--r--dev-python/flaky/flaky-3.6.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/flaky/Manifest b/dev-python/flaky/Manifest
index 9069bc3c223b..d027274ff32b 100644
--- a/dev-python/flaky/Manifest
+++ b/dev-python/flaky/Manifest
@@ -1,3 +1,4 @@
DIST flaky-3.1.1.tar.gz 29136 BLAKE2B fe2f47356e0279885cc294f22bc4588b502c7ada1d3f7a3728b1e3127f011f5900187669bb4e0755e706a1bd77e1804c42986a07c6d3dc58fe085967adb6957c SHA512 039ad115a52b8b3a31bba045874e1860f1e04ea9cf878316226fb22af3c715b3893570c2f7380cf8467107f1a83a4ff69d0e9135daeb2dbea4b8f873a192815c
DIST flaky-3.4.0.tar.gz 29197 BLAKE2B 8f551a414cb06f5259d37785eb769a77105b1039398462288eeaeeb6acea8456c30cc7da6cf515cd99be2adb19a77282d2d0d3abe795761985f45ffd062de508 SHA512 14fda6312e4eb8260a8190204622a7dd274d0c946dda07ec8aa65e8c341f7f4a701c704c807f50eacf77589231b37c3bb06eec18d60a718f24e9b0182f7e8cb5
DIST flaky-3.5.3.tar.gz 29320 BLAKE2B 6bd2095cd481fdd8311e08c3e8aaff78fe22bfefd8463ea3b8190a469d8f909039267256afa876a22a57eae9e390af8235b10211509fe8549d000ed7e9331baa SHA512 9ecb80ab1ec2e0db96b7a7a5856a147434c22d29a603e76d3db3f8d94ddea06ecab799943179910bc1d9d8d5dc1c7bcc94156628352479d67e2dcaaf5cbabf27
+DIST flaky-3.6.1.tar.gz 29501 BLAKE2B 57d8c1ed9f271688f8a6f2acf25456058b3a67c86ea7aac8c32fd52221d294b5226461b9260677e3ed94af84ff9993a02e79f0d6b01f05daee2992efd8ad03b8 SHA512 f14fbd9259759f3b6f18a7dc16e00717ce54392a10cd9b3225636e33c904e69c6b01398bfce96d7273a40b6c2cca897a05ad386a4d8a83bffee12fab322f9b32
diff --git a/dev-python/flaky/flaky-3.6.1.ebuild b/dev-python/flaky/flaky-3.6.1.ebuild
new file mode 100644
index 000000000000..ce46ead9aa05
--- /dev/null
+++ b/dev-python/flaky/flaky-3.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for nose or py.test that automatically reruns flaky tests"
+HOMEPAGE="https://pypi.org/project/flaky/ https://github.com/box/flaky"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/genty[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+python_test() {
+ nosetests --with-flaky --exclude="test_nose_options_example" test/test_nose/ || die
+ pytest -k 'example and not options' --doctest-modules test/test_pytest/ || die
+ pytest -p no:flaky test/test_pytest/test_flaky_pytest_plugin.py || die
+ nosetests --with-flaky --force-flaky --max-runs 2 test/test_nose/test_nose_options_example.py || die
+ pytest --force-flaky --max-runs 2 test/test_pytest/test_pytest_options_example.py || die
+}