summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-21 09:19:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-21 09:19:07 +0300
commit1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187 (patch)
treedd50913a06a887e77db841c314d58732c976105a /dev-python/flask-api
parentmedia-libs/ladspa-sdk: bump to 1.17, cleanup and update (diff)
downloadgentoo-1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187.tar.gz
gentoo-1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187.tar.bz2
gentoo-1e1bb3afd0e613dc5e21a6f94ba1c12fe0c8b187.zip
dev-python/flask-api: add 3.0, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flask-api')
-rw-r--r--dev-python/flask-api/Manifest1
-rw-r--r--dev-python/flask-api/flask-api-3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/flask-api/Manifest b/dev-python/flask-api/Manifest
index 09bcfbe4a912..536afd7f973b 100644
--- a/dev-python/flask-api/Manifest
+++ b/dev-python/flask-api/Manifest
@@ -1 +1,2 @@
DIST flask-api-2.0.tar.gz 235593 BLAKE2B fadd746d91cc2c797a2e40ee6b11532eb0184a1289a692f8de844501a6656eaa1e87d10811119f267344185b22ed5c12bca43198d64d50ca8055ce95d0f62f19 SHA512 631e69e5a786598e6b5ef7e02c5c4f293eadd84d86fdf0155771d04fb6e87be5686756db90ab265cc097ae3d623c31dcebf5096a62c660d6f7d6fb1c3f3d4e3f
+DIST flask-api-3.0.tar.gz 249620 BLAKE2B 63ce0ce6a2d4755caf40c020fc6b88f3b585b0c30f5800df62c8e442f629b8b489917ff0f0d1266d941478336f38aa0560c144620f6c11d60cbd9e31870bf984 SHA512 c86b919f8681a73be166ddc50022faecb376b1b6f99bd0d78b2f2fc8b64f82bf82779dbdcfbcaa1c5e321ea2d286b95f1a1aab32864e6c3923417d7828c7c79a
diff --git a/dev-python/flask-api/flask-api-3.0.ebuild b/dev-python/flask-api/flask-api-3.0.ebuild
new file mode 100644
index 000000000000..0d56985e7d61
--- /dev/null
+++ b/dev-python/flask-api/flask-api-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browsable web APIs for Flask"
+HOMEPAGE="https://www.flaskapi.org/"
+# pypi mirror don't have docs folder
+SRC_URI="https://github.com/flask-api/flask-api/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ local DOCS=( docs/about/release-notes.md docs/api-guide/* docs/index.md )
+ distutils-r1_python_install_all
+}