summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-06 10:23:46 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-06 11:00:37 +0100
commit272783879531c275520edb1ca2133b0882d06773 (patch)
tree5a8c9670a7dc794efc614e43b8251ddbf015ab26 /dev-python/flask-cors
parentdev-python/httpretty: Bump to 1.0.5 (diff)
downloadgentoo-272783879531c275520edb1ca2133b0882d06773.tar.gz
gentoo-272783879531c275520edb1ca2133b0882d06773.tar.bz2
gentoo-272783879531c275520edb1ca2133b0882d06773.zip
dev-python/flask-cors: Bump to 3.0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-cors')
-rw-r--r--dev-python/flask-cors/Manifest1
-rw-r--r--dev-python/flask-cors/flask-cors-3.0.10.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-cors/Manifest b/dev-python/flask-cors/Manifest
index e08914b0b6f9..a68d2afdb125 100644
--- a/dev-python/flask-cors/Manifest
+++ b/dev-python/flask-cors/Manifest
@@ -1 +1,2 @@
+DIST flask-cors-3.0.10.tar.gz 31012 BLAKE2B 2e546518c8183dfca32308ef0f7d8f503c75ff62302d11ac0dc315f7c6760fa3e9064477216fd8c2cd290b0a280e6c45c35cf2cce3cfdffe141edab7beca1c8a SHA512 4471e94aea92700185a6fca37f01d61b9b966754f206eb6211813fb8c82fc0d219597e3df80e9d80b68663931ec561ca209fe23afa0142345fb75beacf3adc4e
DIST flask-cors-3.0.9.tar.gz 29222 BLAKE2B 5c13218728c1741c455efedcf46af0b7e2c765e41ad256eb52413f06544d6d0d1d755ab336bc4a2a44627665b1252246073acfd201622604db825dbd7e2501ed SHA512 1b80b4dbc928e076c8c415f4514877c2e44e5b658b200178dc9a63b3342e46a7da62eba80d6703cdfd6ac74302aae2ff072531a587e7f04e5c1715d8b7592654
diff --git a/dev-python/flask-cors/flask-cors-3.0.10.ebuild b/dev-python/flask-cors/flask-cors-3.0.10.ebuild
new file mode 100644
index 000000000000..bb4da6fa9664
--- /dev/null
+++ b/dev-python/flask-cors/flask-cors-3.0.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/wcdolphin/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/corydolphin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A Flask extension for Cross Origin Resource Sharing (CORS)"
+HOMEPAGE="https://github.com/wcdolphin/flask-cors https://pypi.org/project/Flask-Cors/"
+
+LICENSE="MIT"
+SLOT="0"
+
+BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme