summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-09-13 14:47:04 +0200
committerTiziano Müller <dev-zero@gentoo.org>2016-09-13 14:53:22 +0200
commit6f00b983e678b186d0bb207eab8a77c366ba513d (patch)
tree5da8f8927655cfdc753f5f56670262e704db557a /dev-python/flask-login/flask-login-0.3.2-r1.ebuild
parentdev-python/flask-mail: rev-bump for EAPI 6 bump and py-3.5 support (diff)
downloadgentoo-6f00b983e678b186d0bb207eab8a77c366ba513d.tar.gz
gentoo-6f00b983e678b186d0bb207eab8a77c366ba513d.tar.bz2
gentoo-6f00b983e678b186d0bb207eab8a77c366ba513d.zip
dev-python/flask-login: rev-bump for EAPI 6 bump, py-3.5 support and working tests
This also uses a new tarball since the one from pypi lacks tests Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/flask-login/flask-login-0.3.2-r1.ebuild')
-rw-r--r--dev-python/flask-login/flask-login-0.3.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/flask-login/flask-login-0.3.2-r1.ebuild b/dev-python/flask-login/flask-login-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..f0451faa433b
--- /dev/null
+++ b/dev-python/flask-login/flask-login-0.3.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Login session support for Flask"
+HOMEPAGE="https://pypi.python.org/pypi/Flask-Login"
+SRC_URI="https://github.com/maxcountryman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+# pypi tarball is missing tests
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/flask-0.10[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' 'python2*' pypy)
+ )"
+
+PATCHES=( "${FILESDIR}/${P}-fix-tests-python2.patch" )
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}