summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-25 17:50:03 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-25 20:09:15 +0100
commitb6ee960edf049af59db390e1ac75ecfb46a631b3 (patch)
tree54fc8dbf261a7809d84af45e1eccd6643a35f434 /dev-python/flask-migrate/flask-migrate-2.5.2.ebuild
parentvirtual/dist-kernel: Bump to 5.10.26 (diff)
downloadgentoo-b6ee960edf049af59db390e1ac75ecfb46a631b3.tar.gz
gentoo-b6ee960edf049af59db390e1ac75ecfb46a631b3.tar.bz2
gentoo-b6ee960edf049af59db390e1ac75ecfb46a631b3.zip
dev-python/flask-migrate: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-migrate/flask-migrate-2.5.2.ebuild')
-rw-r--r--dev-python/flask-migrate/flask-migrate-2.5.2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/flask-migrate/flask-migrate-2.5.2.ebuild b/dev-python/flask-migrate/flask-migrate-2.5.2.ebuild
deleted file mode 100644
index be3781444a5c..000000000000
--- a/dev-python/flask-migrate/flask-migrate-2.5.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-inherit distutils-r1
-
-MY_PN="Flask-Migrate"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="SQLAlchemy database migrations for Flask applications using Alembic"
-HOMEPAGE="https://pypi.org/project/Flask-Migrate/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/alembic-0.7[${PYTHON_USEDEP}]
- >=dev-python/flask-0.9[${PYTHON_USEDEP}]
- >=dev-python/flask-sqlalchemy-1.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/flask-script-0.6[${PYTHON_USEDEP}] )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- esetup.py test || die "Testing failed with ${EPYTHON}"
-}