summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-02 15:03:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-02 15:03:32 +0200
commit7cea1573aa057d264c6dde5cb21f6fd1d206afef (patch)
treee1e57ff5dc784ad95b718bd65956c802536c3bc8 /dev-python/flask-mongoengine
parentdev-perl/Crypt-Rijndael: -r bump for EAPI7 + fixes (diff)
downloadgentoo-7cea1573aa057d264c6dde5cb21f6fd1d206afef.tar.gz
gentoo-7cea1573aa057d264c6dde5cb21f6fd1d206afef.tar.bz2
gentoo-7cea1573aa057d264c6dde5cb21f6fd1d206afef.zip
dev-python/flask-mongoengine: Bump to 0.9.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-mongoengine')
-rw-r--r--dev-python/flask-mongoengine/Manifest1
-rw-r--r--dev-python/flask-mongoengine/flask-mongoengine-0.9.5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/flask-mongoengine/Manifest b/dev-python/flask-mongoengine/Manifest
index 5b30acc0b557..389630af6bfe 100644
--- a/dev-python/flask-mongoengine/Manifest
+++ b/dev-python/flask-mongoengine/Manifest
@@ -1 +1,2 @@
DIST flask-mongoengine-0.9.3.tar.gz 111690 BLAKE2B f94f057bb416715d877154bb2816308324d3f0bb41dfe2002b80ed2f078ab2bffeb62fc7bd53344b7d995111122d0b59a09dfe7700975e151e61fe60f2bdad45 SHA512 15b8031e4f8a9275fa6a602aed8466533fc9e6eb408d8f3316fc8814cc785feeee59dae25f40c1c30371e7e33bcc8727bb866bd99dbee0dc75cf15049576fb3d
+DIST flask-mongoengine-0.9.5.gh.tar.gz 120281 BLAKE2B 454602e7e7f26db731379b01492c6cb1adf01369fd268236407c57753aeb68f17ce62d4c2e665e493d3c7c632e4f263af02b59e6580893afcc7b8659247fb42f SHA512 3588ae25e2f3643f5e240990f424b4f3754cea2f880b7b454c98afb3ea98fd81b783d74a45cf685fe59cfa8159b1ac39e840071f364ce98fb1a25cc9a09e0d5f
diff --git a/dev-python/flask-mongoengine/flask-mongoengine-0.9.5.ebuild b/dev-python/flask-mongoengine/flask-mongoengine-0.9.5.ebuild
new file mode 100644
index 000000000000..118819863c52
--- /dev/null
+++ b/dev-python/flask-mongoengine/flask-mongoengine-0.9.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Flask support for MongoDB and with WTF model forms"
+HOMEPAGE="https://pypi.org/project/flask-mongoengine/"
+SRC_URI="
+ https://github.com/MongoEngine/flask-mongoengine/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# TODO: make it spawn a local mongodb instance
+#RESTRICT="test"
+
+RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/mongoengine-0.7.10[${PYTHON_USEDEP}]
+ dev-python/flask-wtf[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests nose
+
+python_prepare_all() {
+ sed -i -e '/test_requirements/d' setup.py || die
+ sed -i -e '/rednose/d' setup.cfg || die
+
+ # TODO: investigate; new pymongo, wtforms?
+ sed -e 's:test_connection_default:_&:' \
+ -i tests/test_basic_app.py || die
+ sed -e 's:test_unique_with:_&:' \
+ -i tests/test_forms.py || die
+ sed -e 's:test_mongomock:_&:' \
+ -i tests/test_connection.py || die
+
+ distutils-r1_python_prepare_all
+}