summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-openid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-openid')
-rw-r--r--dev-python/flask-openid/Manifest2
-rw-r--r--dev-python/flask-openid/flask-openid-1.2.3.ebuild46
-rw-r--r--dev-python/flask-openid/flask-openid-1.2.4.ebuild46
-rw-r--r--dev-python/flask-openid/metadata.xml8
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-python/flask-openid/Manifest b/dev-python/flask-openid/Manifest
new file mode 100644
index 000000000000..d60228524cd1
--- /dev/null
+++ b/dev-python/flask-openid/Manifest
@@ -0,0 +1,2 @@
+DIST Flask-OpenID-1.2.3.tar.gz 40847 SHA256 5674538d05212b3d9a541d6dbe5d121fe2ecbcdd02e336fe772c9b2226f44a8d SHA512 86003beb3b922f3c1151088ae3880966fa52e5fd087be196f6d5e0e57ef3b3310a3b48ada11931a55c08a67583f1e72eab3d52fc2c1581ffb2c521aa07517291 WHIRLPOOL fe8c885e061b98934a7eca4ec075a15c997f81ce831c150eade313bc5e46e64c71a5a33119d53d7ab73d3587a6b578128421d9c95e2ac7f2d732b506cd698f02
+DIST Flask-OpenID-1.2.4.tar.gz 42570 SHA256 7ac41a5816e32a69333f6798046b7bf73d8d9a6c0051ff8c687c336fe1fefcb2 SHA512 3a9cf29c425747fd2f00b0200c99eece4c66b29e3ef56c78c945f9da1029fceb59053798a26209289625c2e2a2e9118531ac2fced82758c76bc8002ec1d58ae7 WHIRLPOOL b072e34245f3e2d504b424769dcbe29c975fbb4133031bf8e4881592ceec99f9ac897b562b37c9cf33a9ef25074513a1d4db2c8b52950147d3e9d6e10c761dae
diff --git a/dev-python/flask-openid/flask-openid-1.2.3.ebuild b/dev-python/flask-openid/flask-openid-1.2.3.ebuild
new file mode 100644
index 000000000000..6ba345f951aa
--- /dev/null
+++ b/dev-python/flask-openid/flask-openid-1.2.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-OpenID"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="OpenID support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-OpenID"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/flask-0.3[${PYTHON_USEDEP}]
+ >=dev-python/python-openid-2.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-openid/flask-openid-1.2.4.ebuild b/dev-python/flask-openid/flask-openid-1.2.4.ebuild
new file mode 100644
index 000000000000..387208c8082d
--- /dev/null
+++ b/dev-python/flask-openid/flask-openid-1.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-OpenID"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="OpenID support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-OpenID"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/flask-0.3[${PYTHON_USEDEP}]
+ >=dev-python/python-openid-2.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-openid/metadata.xml b/dev-python/flask-openid/metadata.xml
new file mode 100644
index 000000000000..1aeddf3772f4
--- /dev/null
+++ b/dev-python/flask-openid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Flask-OpenID</remote-id>
+ </upstream>
+</pkgmetadata>