summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-03 10:14:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-03 12:35:08 +0200
commita767d96ad38f4cadd9b196395d9a650cb3a192cb (patch)
tree3f2c3773971b19ac0a21e2f33fd920b66e4a459c /dev-python/flask-paranoid
parentdev-python/moto: Bump to 3.1.4 (diff)
downloadgentoo-a767d96ad38f4cadd9b196395d9a650cb3a192cb.tar.gz
gentoo-a767d96ad38f4cadd9b196395d9a650cb3a192cb.tar.bz2
gentoo-a767d96ad38f4cadd9b196395d9a650cb3a192cb.zip
dev-python/flask-paranoid: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-paranoid')
-rw-r--r--dev-python/flask-paranoid/Manifest1
-rw-r--r--dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flask-paranoid/Manifest b/dev-python/flask-paranoid/Manifest
index 11d65eabccef..254610177531 100644
--- a/dev-python/flask-paranoid/Manifest
+++ b/dev-python/flask-paranoid/Manifest
@@ -1 +1,2 @@
DIST flask-paranoid-0.2.0.tar.gz 101084 BLAKE2B 5f1f92679da5f374699c8acc97300085840d47e57f48d935cba60e78782109f70651bb7f804410dbb241b48c96ec08498b8b2cc8c18573f14d0bc7972b746d19 SHA512 0d642999fa4d5b795c3dcecc586fc1600cdfceec4adb38bb87ca8be9825d9ddafabb07d98df573a89e61a44a0abd27cbbd21524237b0e23b337a7d5e32ddfdae
+DIST flask-paranoid-0.3.0.gh.tar.gz 102495 BLAKE2B a892c62b3d821d9b8c31567e1d4fdf3f01d990c28f0ab9d8e5a16cc3a6cd78ba06301cbea61048f89db46020051a0426f5abba7fbe43ca09bca5a2c69e904a54 SHA512 68e49a79e7e00c3a89bcc0347c41b80634b3f5f64227f4ae44db95a286a57b6101dff8f7aba592b8d325b38effc58744ee15d56bd8be30507b76c5dc836fc112
diff --git a/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild b/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild
new file mode 100644
index 000000000000..24102c35c237
--- /dev/null
+++ b/dev-python/flask-paranoid/flask-paranoid-0.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple user session protection extension for Flask"
+HOMEPAGE="https://github.com/miguelgrinberg/flask-paranoid/"
+SRC_URI="
+ https://github.com/miguelgrinberg/flask-paranoid/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest