summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:38 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:38 +0100
commit640eaf4dfcc62b1e9ffc88e7d31de690e737e032 (patch)
treeae3e513514d45a838693f542fac76bfa9d3373e5 /dev-python/flask-script/flask-script-2.0.5-r1.ebuild
parentdev-python/flask-nav: Remove old (diff)
downloadgentoo-640eaf4dfcc62b1e9ffc88e7d31de690e737e032.tar.gz
gentoo-640eaf4dfcc62b1e9ffc88e7d31de690e737e032.tar.bz2
gentoo-640eaf4dfcc62b1e9ffc88e7d31de690e737e032.zip
dev-python/flask-script: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/flask-script/flask-script-2.0.5-r1.ebuild')
-rw-r--r--dev-python/flask-script/flask-script-2.0.5-r1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/flask-script/flask-script-2.0.5-r1.ebuild b/dev-python/flask-script/flask-script-2.0.5-r1.ebuild
deleted file mode 100644
index 7e2b014394a8..000000000000
--- a/dev-python/flask-script/flask-script-2.0.5-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 pypy )
-
-inherit distutils-r1
-
-MY_PN="Flask-Script"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flask support for writing external scripts"
-HOMEPAGE="https://flask-script.readthedocs.io/en/latest/
- https://flask-script.readthedocs.io/en/latest/
- https://pypi.org/project/Flask-Script/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-python/flask-0.10.1-r1[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test tests.py || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}