summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-17 20:29:36 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-18 17:06:06 +0800
commitf40039cf95bcf42ce489ecf43da0ffedcaa07b06 (patch)
treeb0a6f0063258d72c0abdac0e88f0af9cc3f8b6ed /dev-python/flask-testing
parentdev-python/speaklater: Fix Python 3 support, add Python 3.5 and tests (diff)
downloadgentoo-f40039cf95bcf42ce489ecf43da0ffedcaa07b06.tar.gz
gentoo-f40039cf95bcf42ce489ecf43da0ffedcaa07b06.tar.bz2
gentoo-f40039cf95bcf42ce489ecf43da0ffedcaa07b06.zip
dev-python/flask-testing: add Python 3 support, fix tests and dependencies
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1293 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/flask-testing')
-rw-r--r--dev-python/flask-testing/flask-testing-0.4.2.ebuild13
-rw-r--r--dev-python/flask-testing/metadata.xml2
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-python/flask-testing/flask-testing-0.4.2.ebuild b/dev-python/flask-testing/flask-testing-0.4.2.ebuild
index c9c8d5279031..25849795db36 100644
--- a/dev-python/flask-testing/flask-testing-0.4.2.ebuild
+++ b/dev-python/flask-testing/flask-testing-0.4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
inherit distutils-r1
@@ -20,18 +20,17 @@ KEYWORDS="amd64 x86"
IUSE="test"
RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/twill[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep 'dev-python/twill[${PYTHON_USEDEP}]' python2_7)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
+ ${RDEPEND}
dev-python/blinker[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}"/${PV}-test-fix.patch )
python_test() {
- # test phase appears to run only py2.7 but if it passes for py2.7 is passes for pypy
- nosetests || die "Testing failed with ${EPYTHON}"
+ esetup.py test
}
diff --git a/dev-python/flask-testing/metadata.xml b/dev-python/flask-testing/metadata.xml
index d2f55a298144..186145be8e10 100644
--- a/dev-python/flask-testing/metadata.xml
+++ b/dev-python/flask-testing/metadata.xml
@@ -7,5 +7,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">Flask-Testing</remote-id>
+ <remote-id type="github">jarus/flask-testing</remote-id>
+ <bugs-to>https://github.com/jarus/flask-testing/issues</bugs-to>
</upstream>
</pkgmetadata>