summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-03 21:49:15 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-03 21:51:00 -0700
commit92e9d6623c0e0a87710dcf5306bf8dac59649ec1 (patch)
tree90345b0d5969c8dee487f9734ccc2c46813a4aa6 /dev-python/flask
parentdev-ruby/sparklines: add ruby23 (diff)
downloadgentoo-92e9d6623c0e0a87710dcf5306bf8dac59649ec1.tar.gz
gentoo-92e9d6623c0e0a87710dcf5306bf8dac59649ec1.tar.bz2
gentoo-92e9d6623c0e0a87710dcf5306bf8dac59649ec1.zip
dev-python/flask: version bump to 0.12.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-0.12.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 431273c0fc1b..a206d02374e2 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,2 +1,3 @@
DIST Flask-0.10.1.tar.gz 544247 SHA256 4c83829ff83d408b5e1d4995472265411d2c414112298f2eb4b359d9e4563373 SHA512 0008d62d03a46b071c7d0510513d011a9bfd2b77df7f677371a446ca9805d16b1ee5e17dd8dd7cde6443a629370234e44735e20381de20a7da385969797f053f WHIRLPOOL f30a306ed00fe6d4c8e47b781c556c576b99b3545f833ae06f6b778d91c3127dc0adcc34d48221a0f1db1bb1633f2329d6085b7a4550afc672530525fdff474f
+DIST Flask-0.12.1.tar.gz 548511 SHA256 9dce4b6bfbb5b062181d3f7da8f727ff70c1156cbb4024351eafd426deb5fb88 SHA512 23a376ed452bbf874eeeff959924bf8aee51fc9196af71092a7a457742a635fb3adaa958e61625522e93a14092e3bb88a22a74ef419513ca1ae93a1d08723ac5 WHIRLPOOL 29e1c55d094673cb1150780cac5deb1c2964a71e7030b4b4d32dd633fd7631d48687171cf1e745302e0c4dd40d4807a2467ca8c9c4fc9ada4e5d22a35cf3875d
DIST Flask-0.12.tar.gz 531923 SHA256 93e803cdbe326a61ebd5c5d353959397c85f829bec610d59cb635c9f97d7ca8b SHA512 b8e9e005a850fcba413ad151998768ea0facb68f05855a1934cc6e4de1438cb59a4dd1bc74d2b04d52b3e837afa0a7785e98ae6c5af363a894c2be64773113f0 WHIRLPOOL df0df8db12b18b50d9ddf43ae925717bf4a67179af1d387020e73d4fb5f0c04c6cc1d6c83504d8dc5cbcb4dc11dcb0b63724499bd3c5b820feb181418d965138
diff --git a/dev-python/flask/flask-0.12.1.ebuild b/dev-python/flask/flask-0.12.1.ebuild
new file mode 100644
index 000000000000..851f950e42f4
--- /dev/null
+++ b/dev-python/flask/flask-0.12.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/pallets/flask/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/blinker-1[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.4[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.21[${PYTHON_USEDEP}]
+ >=dev-python/click-2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/ 'sphinx.ext.intersphinx',//" -i docs/conf.py || die
+ # DeprecationWarning: Flags not at the start of the expression
+ sed -e "s/r'\(.*\)\((?.*)\)'/r'\2\1'/" -i tests/test_basic.py || die
+ # issubclass(ModuleNotFoundError, ImportError)
+ sed -e 's/\(excinfo.type\) is \(ImportError\)/issubclass(\1, \2)/' \
+ -i tests/test_ext.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH=${S}/examples/flaskr:${S}/examples/minitwit${PYTHONPATH:+:${PYTHONPATH}} \
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ use doc && HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}