summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-23 01:16:32 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-23 01:26:32 +0100
commita3243ffa7fe31b72f820ed81adb8e241f59bb6c5 (patch)
tree40b4c90e5d67b4e6aa1a8dbd664caef431c7ae23 /dev-python/flask
parentdev-python/virtualenv-16.7.7: Version bump (diff)
downloadgentoo-a3243ffa7fe31b72f820ed81adb8e241f59bb6c5.tar.gz
gentoo-a3243ffa7fe31b72f820ed81adb8e241f59bb6c5.tar.bz2
gentoo-a3243ffa7fe31b72f820ed81adb8e241f59bb6c5.zip
dev-python/flask: Fix MissingTestRestrict
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/flask-0.12.2.ebuild1
-rw-r--r--dev-python/flask/flask-1.0.2.ebuild1
-rw-r--r--dev-python/flask/flask-1.0.4.ebuild1
-rw-r--r--dev-python/flask/flask-1.1.1.ebuild1
-rw-r--r--dev-python/flask/flask-9999.ebuild1
5 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/flask/flask-0.12.2.ebuild b/dev-python/flask/flask-0.12.2.ebuild
index e5a7abba8cf5..910edf128854 100644
--- a/dev-python/flask/flask-0.12.2.ebuild
+++ b/dev-python/flask/flask-0.12.2.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/click-2[${PYTHON_USEDEP}]
>=dev-python/blinker-1[${PYTHON_USEDEP}]
diff --git a/dev-python/flask/flask-1.0.2.ebuild b/dev-python/flask/flask-1.0.2.ebuild
index 9ac665ced8d5..ae0367b3bdd9 100644
--- a/dev-python/flask/flask-1.0.2.ebuild
+++ b/dev-python/flask/flask-1.0.2.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]
diff --git a/dev-python/flask/flask-1.0.4.ebuild b/dev-python/flask/flask-1.0.4.ebuild
index 80cc931b35be..309a5494f244 100644
--- a/dev-python/flask/flask-1.0.4.ebuild
+++ b/dev-python/flask/flask-1.0.4.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]
diff --git a/dev-python/flask/flask-1.1.1.ebuild b/dev-python/flask/flask-1.1.1.ebuild
index 80cc931b35be..309a5494f244 100644
--- a/dev-python/flask/flask-1.1.1.ebuild
+++ b/dev-python/flask/flask-1.1.1.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]
diff --git a/dev-python/flask/flask-9999.ebuild b/dev-python/flask/flask-9999.ebuild
index 80cc931b35be..309a5494f244 100644
--- a/dev-python/flask/flask-9999.ebuild
+++ b/dev-python/flask/flask-9999.ebuild
@@ -23,6 +23,7 @@ fi
LICENSE="BSD"
SLOT="0"
IUSE="doc examples test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
dev-python/blinker[${PYTHON_USEDEP}]