summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 03:13:16 +0000
committerSam James <sam@gentoo.org>2021-03-04 03:13:16 +0000
commit78f291f00bdc79454abe4b20faa0b380633f0d8b (patch)
tree3b33b32343562e97579294feeaa0cef9fe582f64 /dev-python/flexmock
parentdev-python/frozen-flask: add Python 3.9, modernise (diff)
downloadgentoo-78f291f00bdc79454abe4b20faa0b380633f0d8b.tar.gz
gentoo-78f291f00bdc79454abe4b20faa0b380633f0d8b.tar.bz2
gentoo-78f291f00bdc79454abe4b20faa0b380633f0d8b.zip
dev-python/flexmock: add Python 3.9, modernise
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/flexmock')
-rw-r--r--dev-python/flexmock/flexmock-0.10.4.ebuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/dev-python/flexmock/flexmock-0.10.4.ebuild b/dev-python/flexmock/flexmock-0.10.4.ebuild
index b93e57f3ca2d..22c19f0099f6 100644
--- a/dev-python/flexmock/flexmock-0.10.4.ebuild
+++ b/dev-python/flexmock/flexmock-0.10.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
inherit distutils-r1
@@ -14,21 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )
- "
-RDEPEND=""
+distutils_enable_tests pytest
python_install_all() {
distutils-r1_python_install_all
dodoc -r docs
}
-
-python_test() {
- pytest -vv tests || die "pytest failed"
-}