summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-10 21:12:23 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-10 21:48:33 -0600
commit14520e9da5d860aaf281ea4799e2bfb8d6894a61 (patch)
treeafab05f661303ecd44ca6d4e45218cb7111943b8 /dev-python/flufl-bounce/flufl-bounce-3.0.ebuild
parentdev-python/flufl-lock: 3.2 for mailman (diff)
downloadgentoo-14520e9da5d860aaf281ea4799e2bfb8d6894a61.tar.gz
gentoo-14520e9da5d860aaf281ea4799e2bfb8d6894a61.tar.bz2
gentoo-14520e9da5d860aaf281ea4799e2bfb8d6894a61.zip
dev-python/flufl-bounce: 3.0 for mailman
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/flufl-bounce/flufl-bounce-3.0.ebuild')
-rw-r--r--dev-python/flufl-bounce/flufl-bounce-3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/flufl-bounce/flufl-bounce-3.0.ebuild b/dev-python/flufl-bounce/flufl-bounce-3.0.ebuild
new file mode 100644
index 000000000000..b9fad4a3d53c
--- /dev/null
+++ b/dev-python/flufl-bounce/flufl-bounce-3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Email bounce detectors."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.bounce"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"