summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-02 20:31:39 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-02 20:40:29 +0300
commit7e70e93dea9da9132ad5c130a74e00d54e8478ca (patch)
tree9b88a64c8e0b770477eeb90c5b3c5416428c265a /dev-python/flufl-bounce
parentdev-python/repoze-sphinx-autointerface: mark ALLARCHES (diff)
downloadgentoo-7e70e93dea9da9132ad5c130a74e00d54e8478ca.tar.gz
gentoo-7e70e93dea9da9132ad5c130a74e00d54e8478ca.tar.bz2
gentoo-7e70e93dea9da9132ad5c130a74e00d54e8478ca.zip
dev-python/flufl-bounce: add 4.0, enable py3.10, enable tests
Closes: https://bugs.gentoo.org/797922 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/flufl-bounce')
-rw-r--r--dev-python/flufl-bounce/Manifest1
-rw-r--r--dev-python/flufl-bounce/flufl-bounce-4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/flufl-bounce/Manifest b/dev-python/flufl-bounce/Manifest
index 4f526da0246f..2771fff8fa04 100644
--- a/dev-python/flufl-bounce/Manifest
+++ b/dev-python/flufl-bounce/Manifest
@@ -1 +1,2 @@
DIST flufl-bounce-3.0.1.tar.gz 100217 BLAKE2B d5620d73513a7e5bbfffb212f13bba34ce199a129a217873a8237d8456a7a1854d78cb9b06e4ee763d4dcfdcfdc185e0d67eb3be82ad829c054baced8acfc25c SHA512 9a8d0dec98f8699fd3dff62f5dd831ab5754f11d246b750cfed8ae7ebb771c3c7c1abd4fcceb0f8aa052653802c6e6e5a7bd4711e63b9095ede238817a3cd146
+DIST flufl.bounce-4.0.tar.gz 108623 BLAKE2B 00c9d69d0aab3a4ca6f781dbd32bcc00d33de59371a163589f8be1747144f6cb9f51da57152235cfbc08ded63894402669c0ba4745eeb3c7b60c95cccf6206c7 SHA512 c6dd8cf2f4f0ea7c8698054042dfc9da3bd1a2d9cae082e01a0be9c39018fefba07154e2c9c15b1a00c896e58bb0a6d2063a3c067bec6b464d201bb7b3220e9e
diff --git a/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild b/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild
new file mode 100644
index 000000000000..fb2312fbbe76
--- /dev/null
+++ b/dev-python/flufl-bounce/flufl-bounce-4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Email bounce detectors."
+HOMEPAGE="https://gitlab.com/warsaw/flufl.bounce"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}