summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 19:18:04 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 19:39:32 +0100
commitd51a77d416eb9bf13a63e080f5386120c6bc592b (patch)
treefd7d2cb2bb71ab3dfc660b9fcca9ed2d9c1b6a01 /dev-python/fonttools/fonttools-3.0.ebuild
parentprofiles: mask games-emulation/sdlmess and games-emulation/sdlmametools for r... (diff)
downloadgentoo-d51a77d416eb9bf13a63e080f5386120c6bc592b.tar.gz
gentoo-d51a77d416eb9bf13a63e080f5386120c6bc592b.tar.bz2
gentoo-d51a77d416eb9bf13a63e080f5386120c6bc592b.zip
dev-python/fonttools: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/fonttools/fonttools-3.0.ebuild')
-rw-r--r--dev-python/fonttools/fonttools-3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/fonttools/fonttools-3.0.ebuild b/dev-python/fonttools/fonttools-3.0.ebuild
new file mode 100644
index 000000000000..2c5409582d66
--- /dev/null
+++ b/dev-python/fonttools/fonttools-3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/behdad/fonttools/"
+SRC_URI="https://github.com/behdad/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/numpy-1.0.2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_install_all() {
+ DOCS=( README.md Doc/{changes.txt,install.txt} )
+ HTML_DOCS=( Doc/documentation.html )
+ distutils-r1_python_install_all
+}