summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/formencode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/formencode')
-rw-r--r--dev-python/formencode/Manifest2
-rw-r--r--dev-python/formencode/formencode-1.2.4.ebuild29
-rw-r--r--dev-python/formencode/formencode-1.3.0-r1.ebuild45
-rw-r--r--dev-python/formencode/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/formencode/Manifest b/dev-python/formencode/Manifest
new file mode 100644
index 000000000000..66f91a3d8073
--- /dev/null
+++ b/dev-python/formencode/Manifest
@@ -0,0 +1,2 @@
+DIST FormEncode-1.2.4.tar.gz 240034 SHA256 8270840ee832055463b3d3328f8ae4b881e1fbe84353c97af1d913df3401feb9 SHA512 493c7b40bef72de9587633a46d01feed0d711dfc8a63dc610c706c50673c3201d1eb737f29b3ce2464c5c5d228d03415ceca48472f5baffc548db2604ba4a2f9 WHIRLPOOL aefd1dd670bc54f7775c3e6b59bf032014b992494ced70a8e891de256ad9ded5c3277c35e8794153194ab539d4e46a36b99d23bbd293fd35cad6dc355e395da0
+DIST FormEncode-1.3.0.zip 347674 SHA256 e6757280244a0d04e9cef51beeeafb4124087c27b7944c7d41341d0a30f7af78 SHA512 12c7c9fa36173c209682a6e1d68a074c64c9a5bd30e4f6b6b851b55d43c350ce1f79f666a9176add65f6bde554bc5deeb82ac965005f9457c4c2b0447af0cea9 WHIRLPOOL b2fa93f0f2eb2c417da43f22f41cb27edf18346560468927fc320aa93c1f6614ec7b76860427f843e3b50017a907c110a05269d281c76f99415b76480d395645
diff --git a/dev-python/formencode/formencode-1.2.4.ebuild b/dev-python/formencode/formencode-1.2.4.ebuild
new file mode 100644
index 000000000000..c8dec4e487c9
--- /dev/null
+++ b/dev-python/formencode/formencode-1.2.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="FormEncode"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML form validation, generation, and conversion package"
+HOMEPAGE="http://formencode.org/ http://pypi.python.org/pypi/FormEncode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/*.txt"
diff --git a/dev-python/formencode/formencode-1.3.0-r1.ebuild b/dev-python/formencode/formencode-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..e1eba513df30
--- /dev/null
+++ b/dev-python/formencode/formencode-1.3.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="FormEncode"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="HTML form validation, generation, and conversion package"
+HOMEPAGE="http://formencode.org/ http://pypi.python.org/pypi/FormEncode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-1.12.0-r1[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+RESTRICT="test"
+DOCS=( docs/. )
+
+S="${WORKDIR}/${MY_P}"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -e '/package_data.*..docs/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # https://github.com/formencode/formencode/issues/78
+ # 5 failures under py2.7. Although the package claims to cater to py3, the suite fails horribly
+ # Main problem is that it is written requiring to be system installed, then run.
+ # Suite found to pass on extended testing using tox.
+ nosetests || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/formencode/metadata.xml b/dev-python/formencode/metadata.xml
new file mode 100644
index 000000000000..c05d7f72e27f
--- /dev/null
+++ b/dev-python/formencode/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">FormEncode</remote-id>
+ </upstream>
+</pkgmetadata>