summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-24 17:03:27 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-24 19:29:51 +0200
commitb5905de151318a4da80cce91617c5b98681e631d (patch)
treee174f19248aef34333412700e07c2a6f7392972f /dev-python/fritzconnection
parentapp-emulation/runc: Stabilize 1.0.0 arm64, #802948 (diff)
downloadgentoo-b5905de151318a4da80cce91617c5b98681e631d.tar.gz
gentoo-b5905de151318a4da80cce91617c5b98681e631d.tar.bz2
gentoo-b5905de151318a4da80cce91617c5b98681e631d.zip
dev-python/fritzconnection: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fritzconnection')
-rw-r--r--dev-python/fritzconnection/Manifest1
-rw-r--r--dev-python/fritzconnection/fritzconnection-1.6.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/fritzconnection/Manifest b/dev-python/fritzconnection/Manifest
index 083c78617f10..26dcdcbdd12f 100644
--- a/dev-python/fritzconnection/Manifest
+++ b/dev-python/fritzconnection/Manifest
@@ -1 +1,2 @@
DIST fritzconnection-1.5.0.tar.gz 71597 BLAKE2B 2c0d27cf91550a7b7f0d3c56f115dd174995af4293d6dd91ee6bbfaab2f3db7c8e4a2297d83a5d6a5219550ee9397c0b1122260234b6fab4589e15c34a381f21 SHA512 2fcf84c73af146d0422a9e32364562e4cc9d6992f487f40f27eede4a571c4dfa37c92a6bcd5ea49da144585657e382e648e0fd00a15f78646da5abb5060eea3c
+DIST fritzconnection-1.6.0.tar.gz 73672 BLAKE2B 25f6b876026bc70397dca171c90d863b4dd3af81f4f3f26bd9a34bed9241c716e98e1305adcbd87a1aa52a21fd6517eda21db0cd9d02d8df5db143ec0f60f5f4 SHA512 c4517774be0913f71e37e982dd87a7076efd81903036193ff37dc2ffd5530829f5f860b773c2b107ca6734ff1b04009243ccb8b2857261911b5a7bcf6e6a528f
diff --git a/dev-python/fritzconnection/fritzconnection-1.6.0.ebuild b/dev-python/fritzconnection/fritzconnection-1.6.0.ebuild
new file mode 100644
index 000000000000..00eeb7787fd3
--- /dev/null
+++ b/dev-python/fritzconnection/fritzconnection-1.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Lib/tool to communicate with AVM FRITZ! devices using TR-064 protocol over UPnP"
+HOMEPAGE="https://github.com/kbr/fritzconnection"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/kbr/fritzconnection"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kbr/fritzconnection/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+RDEPEND=">=dev-python/requests-2.22[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest