summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-16 11:38:29 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-16 11:40:21 +0100
commit097249f7cd847341f76a4e1f95dfa3489c8e3f11 (patch)
tree608bd860596d2ef780e7834efe20118bc8c9f9cb /dev-python/fsspec
parentdev-python/fsspec: Fix tests (diff)
downloadgentoo-097249f7cd847341f76a4e1f95dfa3489c8e3f11.tar.gz
gentoo-097249f7cd847341f76a4e1f95dfa3489c8e3f11.tar.bz2
gentoo-097249f7cd847341f76a4e1f95dfa3489c8e3f11.zip
dev-python/fsspec: Bump to 0.8.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-0.8.5.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index bb16f1f98989..068df8d26c89 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-0.8.2.tar.gz 238399 BLAKE2B f64f153dd303bd3ec44e5010507704b5cbb50a89ad4a7a2e50b38b139219896be543bcff0fe0a99e06f015450f4b0334a641fabeeeb23583b14665ef8f089159 SHA512 e30badc56871ef20cf4b2ce0f6353b4125632d9e253f68d4b08535c9e1ac5fe428745315cee89a9536bfd1b308a28cc65fff555a7b9d9511225357bf790b9aac
+DIST filesystem_spec-0.8.5.tar.gz 255904 BLAKE2B df400276dbc53a453e9e9a00acb2e93a86a5f239237533bab036a16bd48d6d709f68241febe75f6f72281162ba4a563a087405a1064e18805ce2501095d778fb SHA512 20001fd02348f15e764a9e20eab98267f6746bd7e86187914d3db3098061aa62cb296595c3519696ae1e99ef896d49df0fcec846aaf6e5c281dd1a344ef6c393
diff --git a/dev-python/fsspec/fsspec-0.8.5.ebuild b/dev-python/fsspec/fsspec-0.8.5.ebuild
new file mode 100644
index 000000000000..42f59375ae3e
--- /dev/null
+++ b/dev-python/fsspec/fsspec-0.8.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/fsspec-0.8.2-test-cleanup.patch
+)
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # sftp and smb require server started via docker
+ pytest -vv \
+ --ignore fsspec/implementations/tests/test_sftp.py \
+ --ignore fsspec/implementations/tests/test_smb.py ||
+ die "Tests failed with ${EPYTHON}"
+}