summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-01 06:48:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-01 06:55:25 +0200
commit450d907b73ee38600b54f32a5ebbe45d58aef4ec (patch)
tree80be2ed14255005b39b778485057fe4d5c2369e0 /dev-python/fsspec
parentdev-python/google-auth: Bump to 2.0.2 (diff)
downloadgentoo-450d907b73ee38600b54f32a5ebbe45d58aef4ec.tar.gz
gentoo-450d907b73ee38600b54f32a5ebbe45d58aef4ec.tar.bz2
gentoo-450d907b73ee38600b54f32a5ebbe45d58aef4ec.zip
dev-python/fsspec: Bump to 2021.08.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2021.08.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index a90fa0c65150..559db7428e94 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2021.07.0.tar.gz 301517 BLAKE2B 84b189e636eaeb4d3724e1afc44795e83b3ac576ab8640b4fee916bb7cf341c5cd6b1b475616225927693d13f204a1750f913f2e6d35b541fb8ff26ee1019400 SHA512 bea483734e6c9773d93ee93b526c8074a28f0671fbee17b39858dc7a75fd71553ca6d8d5c4e2204446bca3e7c23f6d4c8e94b62ff920e546a2b71786d0dcb388
+DIST filesystem_spec-2021.08.1.tar.gz 303969 BLAKE2B bc67e980cb7d5def227feec16d984630703e817fb696fafd53db7c56634e8e101ac8a68ad6d3ea3b0cbed475f431b5847e3e0612cd1f5abc2bd753ef4f6004e0 SHA512 7757480ff8f113715bdf4be400af9b9c5a3f8b52abc8cc8ccc608f2fea0f3c77f074db1aa5e7ce5d0462ae86a702af8058f8a8935b99617e6803bc7344801b8e
diff --git a/dev-python/fsspec/fsspec-2021.08.1.ebuild b/dev-python/fsspec/fsspec-2021.08.1.ebuild
new file mode 100644
index 000000000000..9320b0a3cd6a
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.08.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+EPYTEST_DESELECT=(
+ fsspec/tests/test_spec.py::test_find
+)
+
+EPYTEST_IGNORE=(
+ # sftp and smb require server started via docker
+ fsspec/implementations/tests/test_dbfs.py
+ fsspec/implementations/tests/test_sftp.py
+ fsspec/implementations/tests/test_smb.py
+)