summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 09:06:35 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 10:34:06 +0200
commit9d5fdd1631259191d89fca6b6f263066eda98cd4 (patch)
tree64c9fa910fd89dbbef6e2c8c39cb124de7ccd728 /dev-python/fsspec
parentdev-python/asyncstdlib: Bump to 3.9.2 (diff)
downloadgentoo-9d5fdd1631259191d89fca6b6f263066eda98cd4.tar.gz
gentoo-9d5fdd1631259191d89fca6b6f263066eda98cd4.tar.bz2
gentoo-9d5fdd1631259191d89fca6b6f263066eda98cd4.zip
dev-python/fsspec: Bump to 2021.05.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-2021.05.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index 34d4148f0f37..5feda806d546 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-2021.04.0.tar.gz 288179 BLAKE2B 896982345533fef9593f393209202e0a90473e9826ced9d69854dca20c66c64b85e1b1c44413dda718cdd1af7f41ac821b4d67b600536b32a873a4f73ab32801 SHA512 6806d6fbae89b514955a309346f19b2d199db10aecece728d117798368c311e3fbb38161fd5a54ea4a60ee7e656d2e50fdf8c4444ec3d6bdd761229b4a6341f2
+DIST filesystem_spec-2021.05.0.tar.gz 292796 BLAKE2B 5d56d860ced1a72c27d2031b7d257a4bcbd52f6b2fed5275fbcbf7088375fde26652f0a003e919ebd3948d5e9833d802304234282ca858a7a2a19bfa11f66aa8 SHA512 7c27a1ad4e21efdcc0f31f91a9929e4c09db7b9421e7bf8d2f485e961f6887a4a5c083f38f8d7b09005a4cf11f55c93cce4617e3dc6c2b241ed20f7847ad711e
diff --git a/dev-python/fsspec/fsspec-2021.05.0.ebuild b/dev-python/fsspec/fsspec-2021.05.0.ebuild
new file mode 100644
index 000000000000..4032b21e0f99
--- /dev/null
+++ b/dev-python/fsspec/fsspec-2021.05.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # sftp and smb require server started via docker
+ epytest \
+ --deselect fsspec/tests/test_spec.py::test_find \
+ --ignore fsspec/implementations/tests/test_dbfs.py \
+ --ignore fsspec/implementations/tests/test_sftp.py \
+ --ignore fsspec/implementations/tests/test_smb.py
+}