summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-06 18:30:47 +0000
committerSam James <sam@gentoo.org>2020-12-06 18:30:47 +0000
commitbbae9b7ed1b6ace87a4ec8c17c5eef348e25e557 (patch)
treeec08593d9d9fb3a97bca46aac285f8c3c679e465 /dev-python/fsspec
parentdev-python/eventlet: bump to 0.29.1 (diff)
downloadgentoo-bbae9b7ed1b6ace87a4ec8c17c5eef348e25e557.tar.gz
gentoo-bbae9b7ed1b6ace87a4ec8c17c5eef348e25e557.tar.bz2
gentoo-bbae9b7ed1b6ace87a4ec8c17c5eef348e25e557.zip
dev-python/fsspec: bump to 0.8.4
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-0.8.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index bb16f1f98989..e3df0357ffdb 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1 +1,2 @@
DIST filesystem_spec-0.8.2.tar.gz 238399 BLAKE2B f64f153dd303bd3ec44e5010507704b5cbb50a89ad4a7a2e50b38b139219896be543bcff0fe0a99e06f015450f4b0334a641fabeeeb23583b14665ef8f089159 SHA512 e30badc56871ef20cf4b2ce0f6353b4125632d9e253f68d4b08535c9e1ac5fe428745315cee89a9536bfd1b308a28cc65fff555a7b9d9511225357bf790b9aac
+DIST filesystem_spec-0.8.4.tar.gz 245482 BLAKE2B 1029351fbf167ca4f6419cf9017f80e569a4e08f46b4726da376fd0b39c5d4180444fac017cf080119aea46cdddda17572edc69b3ffd4e9737573176ae7a8522 SHA512 11a565f743eb09467bf727a11e79c58a0191bb9ba1d3d216181e3b556f5a1108d9461fd7e7d01fa56d570c27de6829c72f2e340493e22669b46300da1751e8f1
diff --git a/dev-python/fsspec/fsspec-0.8.4.ebuild b/dev-python/fsspec/fsspec-0.8.4.ebuild
new file mode 100644
index 000000000000..efb1de845f31
--- /dev/null
+++ b/dev-python/fsspec/fsspec-0.8.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # sftp and smb require server started via docker
+ pytest -vv \
+ --ignore fsspec/implementations/tests/test_sftp.py \
+ --ignore fsspec/implementations/tests/test_smb.py ||
+ die "Tests failed with ${EPYTHON}"
+}