summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-01-12 12:59:19 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-01-12 12:59:49 +0300
commit485413c48e6e7219bec53525e546f27c1cb211b9 (patch)
treedc3319445d6329164840ebff2815bfa07451cbf5 /dev-python/functest/functest-0.8.8-r1.ebuild
parentmedia-libs/mlt: Fix sed for ricers (diff)
downloadgentoo-485413c48e6e7219bec53525e546f27c1cb211b9.tar.gz
gentoo-485413c48e6e7219bec53525e546f27c1cb211b9.tar.bz2
gentoo-485413c48e6e7219bec53525e546f27c1cb211b9.zip
dev-python: remove last-rited pkgs
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-python/functest/functest-0.8.8-r1.ebuild')
-rw-r--r--dev-python/functest/functest-0.8.8-r1.ebuild29
1 files changed, 0 insertions, 29 deletions
diff --git a/dev-python/functest/functest-0.8.8-r1.ebuild b/dev-python/functest/functest-0.8.8-r1.ebuild
deleted file mode 100644
index 9ee5be32dcd6..000000000000
--- a/dev-python/functest/functest-0.8.8-r1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Functest is a test tool/framework for testing in Python"
-HOMEPAGE="https://pypi.org/project/functest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-python_prepare_all() {
- # purge test folder to avoid file collisions
- sed -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- PATH="scripts:${PATH}" nosetests || die "Tests fail with ${EPYTHON}"
-}